summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--opencpn.install15
3 files changed, 16 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec964efeec99..d149c577b91d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
pkgbase = opencpn-git
pkgdesc = Open Source Chart Plotting / Marine Navigation - Git version
- pkgver = 5.2.0.r217.gffdf4cb6e
+ pkgver = 5.6.0.r1162.gef059cb76
pkgrel = 1
url = http://opencpn.org
- install = opencpn.install
arch = x86_64
arch = aarch64
license = GPL2
makedepends = cmake
makedepends = git
+ makedepends = lsb-release
depends = wxgtk3
- depends = gpsd
depends = portaudio
depends = tinyxml
- depends = hicolor-icon-theme
+ depends = libsndfile
+ depends = libarchive
+ depends = libexif
+ depends = glu
depends = webkit2gtk
- depends = lsb-release
+ depends = wxsvg
+ optdepends = gpsd: GPS position support
provides = opencpn
conflicts = opencpn
source = opencpn-git::git+https://github.com/OpenCPN/OpenCPN.git
sha1sums = SKIP
pkgname = opencpn-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f3919c311a93..99213a0b0549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,33 @@
-# ---------------------------------------------------------------
-# Maintainer: Romain Bazile <gromain.baz@gmail.com>
-# ---------------------------------------------------------------
+# Maintainer: cybuzuma <cybuzuma at vnxs dot de>
+# Contributor: Romain Bazile <gromain.baz@gmail.com>
pkgname=opencpn-git
-pkgver=5.2.0.r217.gffdf4cb6e
+pkgver=5.6.0.r1162.gef059cb76
pkgrel=1
pkgdesc="Open Source Chart Plotting / Marine Navigation - Git version"
arch=('x86_64' 'aarch64')
license=("GPL2")
-depends=('wxgtk3' 'gpsd' 'portaudio' 'tinyxml' 'hicolor-icon-theme' 'webkit2gtk' 'lsb-release')
-makedepends=('cmake' 'git')
+depends=('wxgtk3' 'portaudio' 'tinyxml' 'libsndfile' 'libarchive' 'libexif' 'glu' 'webkit2gtk' 'wxsvg')
+optdepends=('gpsd: GPS position support')
+makedepends=('cmake' 'git' 'lsb-release')
conflicts=('opencpn')
provides=('opencpn')
url="http://opencpn.org"
-install=opencpn.install
source=("$pkgname::git+https://github.com/OpenCPN/OpenCPN.git")
sha1sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long --tags | sed -r 's/^[vV]//;s/\_/\./;s/([^-]*-g)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd $pkgname
+ git describe --long --tags | sed -r 's/^Release.//;s/\_/\./;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
cd $pkgname
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
- -DOCPN_BUNDLE_GSHHS=CRUDE -DOCPN_BUNDLE_TCDATA=ON -DOCPN_BUNDLE_DOCS=ON \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
- -DOCPN_FORCE_GTK3=ON ../
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DOCPN_BUILD_TEST=OFF -DOCPN_VERBOSE=OFF -DOCPN_USE_EXTERN_CURL=ON ..
make
}
diff --git a/opencpn.install b/opencpn.install
deleted file mode 100644
index 0a039b4dd254..000000000000
--- a/opencpn.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-