summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD79
-rw-r--r--fix-appstream-data.hook14
-rw-r--r--fix-appstream-data.sh10
-rw-r--r--pamac.install65
5 files changed, 66 insertions, 150 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a9ee4db7149..67ef17d75a9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pamac-aur
- pkgdesc = A Gtk3 frontend, Package Manager based on libalpm with AUR and Appstream support
- pkgver = 10.0.99
- pkgrel = 2
+ pkgdesc = A Gtk frontend, Package Manager based on libalpm with AUR and Appstream support
+ pkgver = 11.7.1
+ pkgrel = 4
url = https://gitlab.manjaro.org/applications/pamac
install = pamac.install
arch = i686
@@ -10,47 +10,37 @@ pkgbase = pamac-aur
arch = armv6h
arch = armv7h
arch = aarch64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = gettext
makedepends = itstool
- makedepends = vala>=0.46
- makedepends = gtk3>=3.22
- makedepends = asciidoc
+ makedepends = vala
makedepends = meson
makedepends = ninja
makedepends = gobject-introspection
- makedepends = libappindicator-gtk3
makedepends = xorgproto
- depends = glib2>=2.42
- depends = json-glib
- depends = libsoup
- depends = dbus-glib
- depends = polkit
- depends = vte3>=0.38
- depends = gtk3>=3.22
+ makedepends = asciidoc
+ makedepends = git
+ makedepends = systemd
depends = libnotify
+ depends = libhandy
+ depends = libadwaita
+ depends = gtk4
depends = desktop-file-utils
- depends = pacman>=5.2
+ depends = libpamac-aur>=11.6
depends = gnutls>=3.4
depends = git
- depends = appstream-glib>=0.7.18-1
- depends = archlinux-appstream-data
- depends = libhandy
- depends = git
optdepends = polkit-gnome: needed for authentification in Cinnamon, Gnome
optdepends = lxsession: needed for authentification in Xfce, LXDE etc.
- provides = pamac=10.0.99-2
+ provides = pamac=11.7.1-4
+ provides = pamac-cli=11.6.0-5
conflicts = pamac
conflicts = pamac-tray-appindicator
+ conflicts = pamac-cli
options = !emptydirs
options = !strip
- backup = etc/pamac.conf
- source = pamac-10.0.99-2.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/611726156318c13e46ce932f7f7c962119b533e5/pamac-611726156318c13e46ce932f7f7c962119b533e5.tar.gz
- source = fix-appstream-data.sh
- source = fix-appstream-data.hook
- sha256sums = 04b2fe9979ab0ac5351d4d9f8e566953f0075f5eeff8ba2c7a7b1af9ad5c8204
- sha256sums = e9fe7c14d15cbce1d337749cf317e4460bce485b102b5c228b7efa479998d4fa
- sha256sums = c2b943318a01ba1f3dabbf32e48e6a6f4b4b774e167ab86c6bfee31aa4a3424c
+ source = pamac-11.7.1-4.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/61b7570aace3def9b048668fa23a52f08423ecf1/pamac-61b7570aace3def9b048668fa23a52f08423ecf1.tar.gz
+ source = pamac-cli-11.6.0-5.tar.gz::https://gitlab.manjaro.org/applications/pamac-cli/-/archive/3985c4d7e95312f79bb2a7f33766912c329f4697/pamac-cli-3985c4d7e95312f79bb2a7f33766912c329f4697.tar.gz
+ sha256sums = 5202a72287aaaf83530448cacd13940d779e3fe12c0a2dd62eaada9721de9ed0
+ sha256sums = 95b192d8bc71764e50f73394b068e78159d2b1d976a2ae22f943c51cfdd7b9ca
pkgname = pamac-aur
-
diff --git a/PKGBUILD b/PKGBUILD
index fd8dfd99883e..892121b3114e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,74 +1,75 @@
# Contributor: Zeph <zeph33@gmail.com>
# Maintainer: Zeph <zeph33@gmail.com>
# https://gitlab.manjaro.org/packages/extra/pamac
-ENABLE_FLATPAK=0
-ENABLE_SNAPD=0
+ENABLE_FAKE_GNOME_SOFTWARE=0
pkgname=pamac-aur
-pkgver=10.0.99
-pkgrel=2
+pkgver=11.7.1
+pkgrel=4
_pkgfixver=$pkgver
+_pkgfixvercli=11.6.0
+_pkgrelcli=5
-_commit='611726156318c13e46ce932f7f7c962119b533e5'
-sha256sums=('04b2fe9979ab0ac5351d4d9f8e566953f0075f5eeff8ba2c7a7b1af9ad5c8204'
- 'e9fe7c14d15cbce1d337749cf317e4460bce485b102b5c228b7efa479998d4fa'
- 'c2b943318a01ba1f3dabbf32e48e6a6f4b4b774e167ab86c6bfee31aa4a3424c')
+_commit='61b7570aace3def9b048668fa23a52f08423ecf1'
+_commitcli='3985c4d7e95312f79bb2a7f33766912c329f4697'
+sha256sums=('5202a72287aaaf83530448cacd13940d779e3fe12c0a2dd62eaada9721de9ed0'
+ '95b192d8bc71764e50f73394b068e78159d2b1d976a2ae22f943c51cfdd7b9ca')
-pkgdesc="A Gtk3 frontend, Package Manager based on libalpm with AUR and Appstream support"
+pkgdesc="A Gtk frontend, Package Manager based on libalpm with AUR and Appstream support"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://gitlab.manjaro.org/applications/pamac"
-license=('GPL3')
-depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' 'gtk3>=3.22'
- 'libnotify' 'desktop-file-utils' 'pacman>=5.2' 'gnutls>=3.4' 'git'
- 'appstream-glib>=0.7.18-1' 'archlinux-appstream-data' 'libhandy' 'git')
+license=('GPL-3.0-or-later')
+depends=('libnotify' 'libhandy' 'libadwaita' 'gtk4' 'desktop-file-utils' 'libpamac-aur>=11.6' 'gnutls>=3.4' 'git')
optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
'lxsession: needed for authentification in Xfce, LXDE etc.')
-makedepends=('gettext' 'itstool' 'vala>=0.46' 'gtk3>=3.22' 'asciidoc' 'meson' 'ninja' 'gobject-introspection' 'libappindicator-gtk3' 'xorgproto')
-backup=('etc/pamac.conf')
-conflicts=('pamac' 'pamac-tray-appindicator')
-provides=("pamac=$pkgver-$pkgrel")
+makedepends=('gettext' 'itstool' 'vala' 'meson' 'ninja' 'gobject-introspection' 'xorgproto' 'asciidoc' 'git' 'systemd')
+conflicts=('pamac' 'pamac-tray-appindicator' 'pamac-cli')
+provides=("pamac=$_pkgfixver-$pkgrel" "pamac-cli=$_pkgfixvercli-$_pkgrelcli")
options=(!emptydirs !strip)
-
install=pamac.install
-source=("pamac-$pkgver-$pkgrel.tar.gz::$url/-/archive/$_commit/pamac-$_commit.tar.gz"
- fix-appstream-data.sh fix-appstream-data.hook)
+source=("pamac-$_pkgfixver-$pkgrel.tar.gz::$url/-/archive/$_commit/pamac-$_commit.tar.gz"
+ "pamac-cli-$_pkgfixvercli-$_pkgrelcli.tar.gz::$url-cli/-/archive/$_commitcli/pamac-cli-$_commitcli.tar.gz")
+
define_meson=''
-if [ "${ENABLE_FLATPAK}" = 1 ]; then
- depends+=('flatpak')
- define_meson+=' -Denable-flatpak=true'
+if [ "${ENABLE_FAKE_GNOME_SOFTWARE}" = 1 ]; then
+ conflicts+=('pamac-gnome-integration' 'pamac-gnome-integration-dev' 'gnome-software')
+ define_meson+=' -Denable-fake-gnome-software=true'
fi
-if [ "${ENABLE_SNAPD}" = 1 ]; then
- depends+=('snapd' 'snapd-glib')
- define_meson+=' -Denable-snap=true'
-fi
+_srcdir="pamac-$_commit"
+_srcdircli="pamac-cli-$_commitcli"
prepare() {
- cd "$srcdir/pamac-$_commit"
+ cd "${srcdir}/${_srcdir}"
# adjust version string
sed -i -e "s|\"$_pkgfixver\"|\"$pkgver-$pkgrel\"|g" src/version.vala
+ cd "${srcdir}/${_srcdircli}"
+ # adjust version string
+ sed -i -e "s|\"$_pkgfixvercli\"|\"$_pkgfixvercli-$_pkgrelcli\"|g" src/version.vala
}
build() {
- cd "$srcdir/pamac-$_commit"
- mkdir -p builddir
- cd builddir
+ cd "${srcdir}/${_srcdir}"
+ mkdir -p builddir && cd builddir
meson --buildtype=release \
--prefix=/usr \
- -Denable-appindicator=true \
--sysconfdir=/etc $define_meson
- # build
ninja
+
+ cd "${srcdir}/${_srcdircli}"
+ mkdir -p builddir && cd builddir
+ meson setup --prefix=/usr --sysconfdir=/etc --buildtype=release
+ meson compile
}
package() {
- cd "$srcdir/pamac-$_commit/builddir"
-
+ cd "${srcdir}/${_srcdir}/builddir"
DESTDIR="$pkgdir" ninja install
- # cp -r "$srcdir/pamac-$_commit/data/gnome-shell/pamac-updates@manjaro.org" "$pkgdir/usr/share/gnome-shell/extensions"
- # fix appstream issue
- install -Dm644 "$srcdir/fix-appstream-data.hook" "$pkgdir/etc/pacman.d/hooks/fix-appstream-data.hook"
- install -Dm755 "$srcdir/fix-appstream-data.sh" "$pkgdir/etc/pacman.d/hooks.bin/fix-appstream-data.sh"
+ cp -r "$srcdir/pamac-$_commit/data/gnome-shell/pamac-updates@manjaro.org" "$pkgdir/usr/share/gnome-shell/extensions"
+ cd "${srcdir}/${_srcdircli}/builddir"
+ meson install --destdir "$pkgdir"
+
+ install -Dm644 "${srcdir}/${_srcdir}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et:
diff --git a/fix-appstream-data.hook b/fix-appstream-data.hook
deleted file mode 100644
index 9bdff11a3a3e..000000000000
--- a/fix-appstream-data.hook
+++ /dev/null
@@ -1,14 +0,0 @@
-[Trigger]
-Operation = Install
-Operation = Upgrade
-Type = Path
-Target = usr/share/app-info/xmls/*.xml.gz
-
-# attention: hook name before: update-appstream-cache.hook
-
-[Action]
-Description = fix appstream datas for pamac
-When = PostTransaction
-Depends = gzip
-Exec = /etc/pacman.d/hooks.bin/fix-appstream-data.sh
-NeedsTargets
diff --git a/fix-appstream-data.sh b/fix-appstream-data.sh
deleted file mode 100644
index e6c365c059b5..000000000000
--- a/fix-appstream-data.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/bash
-tmp="/tmp/fix-appstream-data"
-while read -r archive; do
- if [[ $(zcat "${archive}" | grep -cm1 '<em>') == "1" ]]; then
- zcat "${archive}" | sed 's|<em>||g;s|<\/em>||g;s|<strong>||g;s|<\/strong>||g' | gzip > "${tmp}"
- cp "${tmp}" "${archive}"
- rm "${tmp}"
- echo " archive ${archive} fixed"
- fi
-done
diff --git a/pamac.install b/pamac.install
index 524f2455707c..811374827e2a 100644
--- a/pamac.install
+++ b/pamac.install
@@ -1,64 +1,13 @@
-msg() {
- ALL_OFF="\e[1;0m"
- BOLD="\e[1;1m"
- GREEN="${BOLD}\e[1;32m"
- local mesg=$1; shift
- printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
-}
-
-restore_conf() {
- PAMAC_NEW="$(date +%m%d%M%S)"
- if [ -f "/etc/pamac.conf.pacsave" ]; then
- msg "You had an old /etc/pamac.conf.pacsave file. We restore it for you."
- msg "You can find your new pamac.conf saved as \`/etc/pamac-new-${PAMAC_NEW}.conf\`"
- mv /etc/pamac.conf /etc/pamac-new-${PAMAC_NEW}.conf
- mv /etc/pamac.conf.pacsave /etc/pamac.conf
- fi
-}
-
post_install() {
- # enable flatpak repo
- if [ -f /usr/bin/flatpak ]; then
- flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
- fi
- # enable systemd timers
- mkdir -p /etc/systemd/system/timers.target.wants
- ln -sf /usr/lib/systemd/system/pamac-cleancache.timer /etc/systemd/system/timers.target.wants/pamac-cleancache.timer
- # ln -sf /usr/lib/systemd/system/pamac-mirrorlist.timer /etc/systemd/system/timers.target.wants/pamac-mirrorlist.timer
- # polkit agent
- printf '==> An authentication agent is required\n'
- printf ' Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce\n'
- printf ' have an authentication agent already.\n'
- printf ' See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents\n'
- printf ' for other desktop environments.\n'
- # restore old conf
- restore_conf
+ # enable pamac extension
+ printf '==> Enable Pamac Updates Indicator via\n'
+ printf ' Extensions\n'
}
post_upgrade() {
- # enable flatpak repo
- if [ -f /usr/bin/flatpak ]; then
- flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
- fi
- # restore old conf
- if [ "$(vercmp $2 7.3.5-3)" -lt 0 ]; then
- restore_conf
+ if [[ ! "gsettings get org.gnome.shell enabled-extensions | grep 'pamac-updates'" ]]; then
+ # enable pamac extension
+ printf '==> Enable Pamac Updates Indicator via\n'
+ printf ' Extensions\n'
fi
-
- if [ "$(vercmp $2 8.0.3-5)" -lt 0 ]; then
- # remove wrong placed symlinks
- msg "Updating timer symlinks"
- [[ -e /etc/systemd/system/multi-user.target.wants/pamac-cleancache.timer ]] && rm -f /etc/systemd/system/multi-user.target.wants/pamac-cleancache.timer
- # [[ -e /etc/systemd/system/multi-user.target.wants/pamac-mirrorlist.timer ]] && rm -f /etc/systemd/system/multi-user.target.wants/pamac-mirrorlist.timer
- # enable systemd timers
- mkdir -p /etc/systemd/system/timers.target.wants
- ln -sf /usr/lib/systemd/system/pamac-cleancache.timer /etc/systemd/system/timers.target.wants/pamac-cleancache.timer
- # ln -sf /usr/lib/systemd/system/pamac-mirrorlist.timer /etc/systemd/system/timers.target.wants/pamac-mirrorlist.timer
- fi
-}
-
-post_remove() {
- # disable systemd timers
- rm -f /etc/systemd/system/timers.target.wants/pamac-cleancache.timer
- # rm -f /etc/systemd/system/timers.target.wants/pamac-mirrorlist.timer
}