summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--pamac.install7
3 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80d69181b7f9..a44245e15250 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pamac-aur
pkgdesc = A Gtk3 frontend for libalpm
pkgver = 9.4.0
- pkgrel = 1
+ pkgrel = 4
url = https://gitlab.manjaro.org/applications/pamac
install = pamac.install
arch = i686
@@ -32,6 +32,7 @@ pkgbase = pamac-aur
depends = git
depends = appstream-glib
depends = archlinux-appstream-data
+ depends = flatpak
optdepends = polkit-gnome: needed for authentification in Cinnamon, Gnome
optdepends = lxsession: needed for authentification in Xfce, LXDE etc.
optdepends = pamac-tray-appindicator: tray icon for KDE
@@ -39,8 +40,8 @@ pkgbase = pamac-aur
conflicts = pamac
options = !emptydirs
backup = etc/pamac.conf
- source = pamac-9.4.0-1.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/v9.4.0/pamac-v9.4.0.tar.gz
- sha256sums = 903e549a425146723fd2ee2813fc960e08100fcfd0a2291cfde4b5c1d8449196
+ source = pamac-9.4.0-4.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/712e0e22958f41c311afe1fc21ef478729fcbe59/pamac-712e0e22958f41c311afe1fc21ef478729fcbe59.tar.gz
+ sha256sums = cca8e5665256870b122ae1398d92b0278d72eb9f4ac31a014cd8176035e0c733
pkgname = pamac-aur
diff --git a/PKGBUILD b/PKGBUILD
index d2017f587964..e441269a6128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# https://gitlab.manjaro.org/packages/extra/pamac
pkgname=pamac-aur
pkgver=9.4.0
-pkgrel=1
+pkgrel=4
_pkgfixver=$pkgver
_pkgvercommit=v$pkgver
-#_pkgvercommit='1686977cd939dcdf8f0c707a2edc0c6a012a99d7'
-sha256sums=('903e549a425146723fd2ee2813fc960e08100fcfd0a2291cfde4b5c1d8449196')
+_pkgvercommit='712e0e22958f41c311afe1fc21ef478729fcbe59'
+sha256sums=('cca8e5665256870b122ae1398d92b0278d72eb9f4ac31a014cd8176035e0c733')
pkgdesc="A Gtk3 frontend for libalpm"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -16,7 +16,7 @@ url="https://gitlab.manjaro.org/applications/pamac"
license=('GPL3')
depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' 'gtk3>=3.22'
'libnotify' 'desktop-file-utils' 'pacman>=5.2' 'gnutls>=3.4' 'git'
- 'appstream-glib' 'archlinux-appstream-data')
+ 'appstream-glib' 'archlinux-appstream-data' 'flatpak')
optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
'lxsession: needed for authentification in Xfce, LXDE etc.'
@@ -41,7 +41,11 @@ build() {
cd "$srcdir/pamac-$_pkgvercommit"
mkdir -p builddir
cd builddir
- meson --buildtype=release --prefix=/usr --sysconfdir=/etc
+ meson --buildtype=release \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Denable-flatpak=true
+# -Denable-snap=true
# build
ninja
@@ -49,7 +53,7 @@ build() {
package() {
cd "$srcdir/pamac-$_pkgvercommit/builddir"
-
+
DESTDIR="$pkgdir" ninja install
}
# vim:set ts=2 sw=2 et:
diff --git a/pamac.install b/pamac.install
index 8437f7321391..8d81c8967f3e 100644
--- a/pamac.install
+++ b/pamac.install
@@ -1,4 +1,6 @@
post_install() {
+ # enable flatpak repo
+ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
# enable systemd timers
ln -sf /usr/lib/systemd/system/pamac-cleancache.timer /etc/systemd/system/multi-user.target.wants
#ln -sf /usr/lib/systemd/system/pamac-mirrorlist.timer /etc/systemd/system/multi-user.target.wants
@@ -10,6 +12,11 @@ post_install() {
printf ' for other desktop environments.\n'
}
+post_upgrade() {
+ # enable flatpak repo
+ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
+}
+
post_remove() {
# disable systemd timers
rm -f /etc/systemd/system/multi-user.target.wants/pamac-cleancache.timer