summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--copy-libatomic_fixes.patch41
3 files changed, 57 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8e4cef928f0..0589b9806fdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = popcorntime
pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch.
- pkgver = 0.5.0
- pkgrel = 2
+ pkgver = 0.5.1
+ pkgrel = 1
url = https://popcorn-time.site/
arch = i686
arch = x86_64
@@ -15,11 +15,13 @@ pkgbase = popcorntime
depends = ttf-font
optdepends = net-tools: vpn.ht client
options = !strip
- source = popcorn-desktop::git+https://github.com/popcorn-official/popcorn-desktop/#tag=v0.5.0
+ source = popcorn-desktop::git+https://github.com/popcorn-official/popcorn-desktop/#tag=v0.5.1
source = popcorntime.desktop
source = yarn_lock-fixes.patch
- sha512sums = SKIP
+ source = copy-libatomic_fixes.patch
+ sha512sums = eebf29848ef0eb37028031056be5303bd86105af5de258d122a6dfe8757c0b27c226df6ae296930b779c3fc849bde161fcb75a6adfe6cda9c5fef8e913a8db48
sha512sums = 7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb
sha512sums = 1cb54fbc2690f4a473e50e786b12f5fcfffffb805cfd421e996bc0b278c13fd1252ab63cde576078eb1d7df060b5763a308a0dec9ffba8a0b568f78a6a326f8b
+ sha512sums = 492173870773112a170db73a92fd7b06dced4a06db580ef5f9d651702eef62e53b5c45e8c7956262f0038c7055841f7aec2d4087c517c7a42ba24748ea4f7ef6
pkgname = popcorntime
diff --git a/PKGBUILD b/PKGBUILD
index 02c3daa706d3..a712557b005b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
# Contributor: Ricardo Band <me [at] xengi [dot] de>
pkgname=popcorntime
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.5.1
+pkgrel=1
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=(i686 x86_64)
url="https://popcorn-time.site/"
@@ -41,10 +41,12 @@ source=(
"${_pkgname}::git+https://github.com/popcorn-official/${_pkgname}/#${_commit_hash}"
"popcorntime.desktop"
"yarn_lock-fixes.patch"
+ "copy-libatomic_fixes.patch"
)
-sha512sums=('SKIP'
+sha512sums=('eebf29848ef0eb37028031056be5303bd86105af5de258d122a6dfe8757c0b27c226df6ae296930b779c3fc849bde161fcb75a6adfe6cda9c5fef8e913a8db48'
'7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb'
- '1cb54fbc2690f4a473e50e786b12f5fcfffffb805cfd421e996bc0b278c13fd1252ab63cde576078eb1d7df060b5763a308a0dec9ffba8a0b568f78a6a326f8b')
+ '1cb54fbc2690f4a473e50e786b12f5fcfffffb805cfd421e996bc0b278c13fd1252ab63cde576078eb1d7df060b5763a308a0dec9ffba8a0b568f78a6a326f8b'
+ '492173870773112a170db73a92fd7b06dced4a06db580ef5f9d651702eef62e53b5c45e8c7956262f0038c7055841f7aec2d4087c517c7a42ba24748ea4f7ef6')
# Building the package
prepare() {
@@ -58,6 +60,10 @@ prepare() {
echo "--> Apply Yarn lockfile fixes ..."
git apply "$srcdir/yarn_lock-fixes.patch"
+ # Fix the libatomic script to work on Arch
+ echo "--> Apply Yarn lockfile fixes ..."
+ git apply "$srcdir/copy-libatomic_fixes.patch"
+
# Thanks to Eschwartz for the tip! yarn edition
export YARN_CACHE_FOLDER="$srcdir/npm_cache"
diff --git a/copy-libatomic_fixes.patch b/copy-libatomic_fixes.patch
new file mode 100644
index 000000000000..236f9fd05afe
--- /dev/null
+++ b/copy-libatomic_fixes.patch
@@ -0,0 +1,41 @@
+diff --git a/dist/linux/copy-libatomic.sh b/dist/linux/copy-libatomic.sh
+index 19f6cebfd..59574ef01 100755
+--- a/dist/linux/copy-libatomic.sh
++++ b/dist/linux/copy-libatomic.sh
+@@ -7,22 +7,24 @@ arch=$3
+
+ outDir="$1/$2/$3"
+
+-sudo dpkg --add-architecture i386
+-dpkg-query -s libatomic1
+-if [ ! $? = 0 ]; then
+- sudo apt update
+- sudo apt install -y libatomic1
+-fi
+-dpkg-query -s libatomic1:i386
+-if [ ! $? = 0 ]; then
+- sudo apt update
+- sudo apt install -y libatomic1:i386
++if command -v dpkg; then
++ sudo dpkg --add-architecture i386
++ dpkg-query -s libatomic1
++ if [ ! $? = 0 ]; then
++ sudo apt update
++ sudo apt install -y libatomic1
++ fi
++ dpkg-query -s libatomic1:i386
++ if [ ! $? = 0 ]; then
++ sudo apt update
++ sudo apt install -y libatomic1:i386
++ fi
+ fi
+
+ if [[ $arch == "linux64" ]]
+ then
+- read source <<< `readlink -f /usr/lib/x86_64*/libatomic.so.*`
++ read source <<< `readlink -f /usr/lib64/libatomic.so.*`
+ else
+- read source <<< `readlink -f /usr/lib/i386*/libatomic.so.*`
++ read source <<< `readlink -f /usr/lib32/libatomic.so.*`
+ fi
+ cp $source "$outDir/lib/libatomic.so.1"