summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02c3daa706d3..a712557b005b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
# Contributor: Ricardo Band <me [at] xengi [dot] de>
pkgname=popcorntime
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.5.1
+pkgrel=1
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=(i686 x86_64)
url="https://popcorn-time.site/"
@@ -41,10 +41,12 @@ source=(
"${_pkgname}::git+https://github.com/popcorn-official/${_pkgname}/#${_commit_hash}"
"popcorntime.desktop"
"yarn_lock-fixes.patch"
+ "copy-libatomic_fixes.patch"
)
-sha512sums=('SKIP'
+sha512sums=('eebf29848ef0eb37028031056be5303bd86105af5de258d122a6dfe8757c0b27c226df6ae296930b779c3fc849bde161fcb75a6adfe6cda9c5fef8e913a8db48'
'7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb'
- '1cb54fbc2690f4a473e50e786b12f5fcfffffb805cfd421e996bc0b278c13fd1252ab63cde576078eb1d7df060b5763a308a0dec9ffba8a0b568f78a6a326f8b')
+ '1cb54fbc2690f4a473e50e786b12f5fcfffffb805cfd421e996bc0b278c13fd1252ab63cde576078eb1d7df060b5763a308a0dec9ffba8a0b568f78a6a326f8b'
+ '492173870773112a170db73a92fd7b06dced4a06db580ef5f9d651702eef62e53b5c45e8c7956262f0038c7055841f7aec2d4087c517c7a42ba24748ea4f7ef6')
# Building the package
prepare() {
@@ -58,6 +60,10 @@ prepare() {
echo "--> Apply Yarn lockfile fixes ..."
git apply "$srcdir/yarn_lock-fixes.patch"
+ # Fix the libatomic script to work on Arch
+ echo "--> Apply Yarn lockfile fixes ..."
+ git apply "$srcdir/copy-libatomic_fixes.patch"
+
# Thanks to Eschwartz for the tip! yarn edition
export YARN_CACHE_FOLDER="$srcdir/npm_cache"