summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa05094f83bf..e7dcba1d64b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = proton-caller-git
pkgdesc = Run any Windows program through Proton
- pkgver = 2.0
+ pkgver = 3.0.1.r0.g9874d3b
pkgrel = 1
url = https://github.com/caverym/Proton-Caller/
arch = x86_64
@@ -8,11 +8,9 @@ pkgbase = proton-caller-git
makedepends = git
makedepends = rust
makedepends = gcc
- depends = steam
provides = proton-caller
conflicts = proton-caller
source = git+https://github.com/caverym/Proton-Caller.git
sha256sums = SKIP
pkgname = proton-caller-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a20eb74b7352..3a23b4dfe673 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Avery Murray <averylapine@gmail.com>
pkgname=proton-caller-git
-pkgver=2.0
+pkgver=3.0.1.r0.g9874d3b
pkgrel=1
pkgdesc="Run any Windows program through Proton"
arch=('x86_64')
@@ -15,6 +15,8 @@ conflicts=(proton-caller)
source=("git+https://github.com/caverym/Proton-Caller.git")
sha256sums=('SKIP')
+validgpgkeys=('CE12C7A298605A16')
+
pkgver() {
cd Proton-Caller
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -22,16 +24,17 @@ pkgver() {
build() {
cd Proton-Caller
- RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo build --release --locked
+ RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo build --release
}
check() {
cd Proton-Caller
- RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo test --release --locked
+ RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo test --release
}
package() {
cd Proton-Caller
install -Dm755 target/release/proton-call "$pkgdir"/usr/bin/proton-call
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 proton.conf "$pkgdir"/usr/share/proton-caller/example.conf
}