summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a20eb74b7352..3a23b4dfe673 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Avery Murray <averylapine@gmail.com>
pkgname=proton-caller-git
-pkgver=2.0
+pkgver=3.0.1.r0.g9874d3b
pkgrel=1
pkgdesc="Run any Windows program through Proton"
arch=('x86_64')
@@ -15,6 +15,8 @@ conflicts=(proton-caller)
source=("git+https://github.com/caverym/Proton-Caller.git")
sha256sums=('SKIP')
+validgpgkeys=('CE12C7A298605A16')
+
pkgver() {
cd Proton-Caller
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -22,16 +24,17 @@ pkgver() {
build() {
cd Proton-Caller
- RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo build --release --locked
+ RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo build --release
}
check() {
cd Proton-Caller
- RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo test --release --locked
+ RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo test --release
}
package() {
cd Proton-Caller
install -Dm755 target/release/proton-call "$pkgdir"/usr/bin/proton-call
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 proton.conf "$pkgdir"/usr/share/proton-caller/example.conf
}