summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rwxr-xr-xpsani23
3 files changed, 34 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 129c690c4a4e..c3536fad41fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
-# Generated by mksrcinfo v8
-# Tue Jun 12 22:03:13 UTC 2018
pkgbase = psani-profi
pkgdesc = Program that will teach you touchtyping (czech)
pkgver = 3.4.01
- pkgrel = 1
+ pkgrel = 2
url = http://www.sallyx.org/sally/psani-vsemi-deseti/
arch = i686
arch = x86_64
license = GPL
depends = bash
- depends = xorg-luit
+ depends = luit
source = http://www.sallyx.org/sally/download.php?file=psani-vsemi-deseti%2Fpsani-profi_3.4.01.tar.gz
+ source = psani
md5sums = 104efc83c44987416386ae6607c96537
+ md5sums = 0fca5f75d5166b2b44a8420217f3099e
pkgname = psani-profi
diff --git a/PKGBUILD b/PKGBUILD
index 536202d69e5e..a79c3c7534c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=psani-profi
pkgver=3.4.01
-pkgrel=1
+pkgrel=2
pkgdesc="Program that will teach you touchtyping (czech)"
arch=('i686' 'x86_64')
url="http://www.sallyx.org/sally/psani-vsemi-deseti/"
license=('GPL')
-depends=('bash' 'xorg-luit')
-source=("http://www.sallyx.org/sally/download.php?file=psani-vsemi-deseti%2F${pkgname}_${pkgver}.tar.gz")
-md5sums=('104efc83c44987416386ae6607c96537')
+depends=(bash luit)
+source=("http://www.sallyx.org/sally/download.php?file=psani-vsemi-deseti%2F${pkgname}_${pkgver}.tar.gz" "psani")
+md5sums=('104efc83c44987416386ae6607c96537'
+ '0fca5f75d5166b2b44a8420217f3099e')
build() {
cd "$srcdir/${pkgname}_${pkgver}/zdrojaky"
@@ -24,6 +25,7 @@ package() {
make DESTDIR=$pkgdir install
# this is useless - we have pacman
rm $pkgdir/usr/bin/${pkgname}-${pkgver}-uninstall.sh
- sed -i '/LC_ALL/s!\(.*\)luit \(.*\)\(/usr/bin/psani-profi.*\)!\1luit \3!' $pkgdir/usr/bin/psani
+ # sed -i '/LC_ALL/s!\(.*\)luit \(.*\)\(/usr/bin/psani-profi.*\)!\1luit \3!' $pkgdir/usr/bin/psani
+ install -Dm755 $srcdir/psani $pkgdir/usr/bin/psani
chown -R root:root $pkgdir/usr/share/psanipb
}
diff --git a/psani b/psani
new file mode 100755
index 000000000000..2699d5f51336
--- /dev/null
+++ b/psani
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# Skript na spousteni programu psani-profi
+#
+
+# Spousteni pomoci nasledujiciho radku vyuzije program luit
+# pro emulovani iso-8859-2 kodovani na UTF-8 terminalech (doporuceno).
+# Pro spravnou funkci je potreba mit nainstalovan program luit.
+
+lang=$(locale -a | perl -ne 'print $1 if /(cs_CZ|sk_SK).iso88592/')
+if [ -z "${lang}" ]
+then
+ echo "Je potreba odkomentovat radek cs_CZ ISO-8859-2 v /etc/locale.gen"
+ echo "a spustit locale-gen -a"
+ exit 1
+fi
+
+LC_ALL=${lang}.ISO-8859-2 luit /usr/bin/psani-profi-3.4.01 $@; exit 0
+
+# Spousteni pomoci nasledujiciho radku spusti program v
+# defaultnim kodovani iso-8859-2
+
+# /usr/bin/psani-profi-3.4.01 $@