summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 536202d69e5e..a79c3c7534c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=psani-profi
pkgver=3.4.01
-pkgrel=1
+pkgrel=2
pkgdesc="Program that will teach you touchtyping (czech)"
arch=('i686' 'x86_64')
url="http://www.sallyx.org/sally/psani-vsemi-deseti/"
license=('GPL')
-depends=('bash' 'xorg-luit')
-source=("http://www.sallyx.org/sally/download.php?file=psani-vsemi-deseti%2F${pkgname}_${pkgver}.tar.gz")
-md5sums=('104efc83c44987416386ae6607c96537')
+depends=(bash luit)
+source=("http://www.sallyx.org/sally/download.php?file=psani-vsemi-deseti%2F${pkgname}_${pkgver}.tar.gz" "psani")
+md5sums=('104efc83c44987416386ae6607c96537'
+ '0fca5f75d5166b2b44a8420217f3099e')
build() {
cd "$srcdir/${pkgname}_${pkgver}/zdrojaky"
@@ -24,6 +25,7 @@ package() {
make DESTDIR=$pkgdir install
# this is useless - we have pacman
rm $pkgdir/usr/bin/${pkgname}-${pkgver}-uninstall.sh
- sed -i '/LC_ALL/s!\(.*\)luit \(.*\)\(/usr/bin/psani-profi.*\)!\1luit \3!' $pkgdir/usr/bin/psani
+ # sed -i '/LC_ALL/s!\(.*\)luit \(.*\)\(/usr/bin/psani-profi.*\)!\1luit \3!' $pkgdir/usr/bin/psani
+ install -Dm755 $srcdir/psani $pkgdir/usr/bin/psani
chown -R root:root $pkgdir/usr/share/psanipb
}