summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--changelog.md541
3 files changed, 539 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18ffe0849254..212b672e7b39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-akshare
pkgdesc = Financial data interface library
- pkgver = 1.5.37
+ pkgver = 1.6.21
pkgrel = 1
url = https://github.com/akfamily/akshare
changelog = changelog.md
@@ -16,7 +16,6 @@ pkgbase = python-akshare
makedepends = python-recommonmark
depends = python-beautifulsoup4
depends = python-lxml
- depends = python-numpy
depends = python-pandas
depends = python-requests
depends = python-requests-cache
@@ -31,7 +30,7 @@ pkgbase = python-akshare
depends = python-tabulate
depends = python-decorator
depends = python-pyminiracer
- source = python-akshare-1.5.37.tar.gz::https://github.com/akfamily/akshare/archive/release-v1.5.37.tar.gz
- sha256sums = acf7a59921536aec60383ad1f4d6fe2215c3307cbedccb16ff98e0ab4662f6d9
+ source = python-akshare-1.6.21.tar.gz::https://github.com/akfamily/akshare/archive/release-v1.6.21.tar.gz
+ sha256sums = 19d2610c2595a16fa743df720e0939a689fb11059fc06ee8f9ffc21a6b24cbf1
pkgname = python-akshare
diff --git a/PKGBUILD b/PKGBUILD
index ab0766252277..d09363da313b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=python-akshare
-pkgver=1.5.37
+pkgver=1.6.21
pkgrel=1
pkgdesc="Financial data interface library"
arch=('any')
@@ -11,7 +11,6 @@ license=('MIT')
depends=(
'python-beautifulsoup4'
'python-lxml'
- 'python-numpy'
'python-pandas'
'python-requests'
'python-requests-cache'
@@ -37,7 +36,7 @@ makedepends=(
'python-recommonmark')
changelog=changelog.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/release-v$pkgver.tar.gz")
-sha256sums=('acf7a59921536aec60383ad1f4d6fe2215c3307cbedccb16ff98e0ab4662f6d9')
+sha256sums=('19d2610c2595a16fa743df720e0939a689fb11059fc06ee8f9ffc21a6b24cbf1')
prepare() {
cd "akshare-release-v$pkgver"
@@ -54,7 +53,6 @@ package() {
cd "akshare-release-v$pkgver"
PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 docs/build/man/akshare.1 -t "$pkgdir/usr/share/man/man1/"
-
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
ln -s \
diff --git a/changelog.md b/changelog.md
index 904441e2e405..75e9e697ef2d 100644
--- a/changelog.md
+++ b/changelog.md
@@ -4,6 +4,16 @@
| AKShare 版本 | 旧接口名称 | 新接口名称 | 修改日期 |
|------------|-----------------------------------|-----------------------------------|----------|
+| 1.5.94 | bond_conv_adj_logs_jsl | bond_cb_adj_logs_jsl | 20220524 |
+| 1.5.94 | bond_cov_jsl | bond_cb_jsl | 20220524 |
+| 1.5.53 | stock_em_xjll | stock_xjll_em | 20220501 |
+| 1.5.53 | stock_em_lrb | stock_lrb_em | 20220501 |
+| 1.5.53 | stock_em_zcfz | stock_zcfz_em | 20220501 |
+| 1.5.52 | stock_em_ggcg | stock_ggcg_em | 20220501 |
+| 1.5.48 | futures_nh_price_index | futures_price_index_nh | 20220428 |
+| 1.5.48 | futures_nh_index_symbol_table | futures_index_symbol_table_nh | 20220428 |
+| 1.5.48 | futures_nh_return_index | futures_return_index_nh | 20220428 |
+| 1.5.46 | stock_em_yzxdr | stock_yzxdr_em | 20220427 |
| 1.5.34 | stock_em_gpzy_industry_data | stock_gpzy_industry_data_em | 20220420 |
| 1.5.26 | stock_em_comment | stock_comment_em | 20220415 |
| 1.5.25 | stock_em_analyst_detail | stock_analyst_detail_em | 20220415 |
@@ -19,6 +29,357 @@
## 更新说明
+1.6.21 fix: fix baidu_search_index interface
+
+ 1. 修复 baidu_search_index 接口
+ 2. 修复 baidu_info_index 接口
+ 3. 修复 baidu_media_index 接口
+
+1.6.20 fix: fix stock_board_industry_name_em and code_id_map_em interface
+
+ 1. 修复 stock_board_industry_name_em 接口,字段容错处理
+ 2. 修复 code_id_map_em 接口,股票超过 5000 只处理
+
+1.6.19 fix: fix stock_comment_detail_zlkp_jgcyd_em interface
+
+ 1. 修复 stock_comment_detail_zlkp_jgcyd_em 接口
+
+1.6.18 fix: fix stock_zh_a_spot_em interface
+
+ 1. 修复 stock_zh_a_spot_em 接口,增加股票获取的数量,目前已经超过 5000 只
+
+1.6.17 fix: fix stock_new_a_spot_em interface
+
+ 1. 修复 stock_new_a_spot_em 接口上市日期字段
+
+1.6.16 fix: fix baidu_search_index interface
+
+ 1. 修复 baidu_search_index 接口,对该接口增加 text 字段
+
+1.6.15 fix: fix bond_zh_cov_info interface
+
+ 1. 修复 bond_zh_cov_info 接口,修改接口参数及返回数据
+
+1.6.14 fix: fix stock_hsgt_board_rank_em interface
+
+ 1. 修复 stock_hsgt_board_rank_em 接口,字段调整
+
+1.6.13 add: add stock_new_a_spot_em interface
+
+ 1. 新增 stock_new_a_spot_em 接口,获取新股行情数据
+
+1.6.12 add: add stock_bj_a_spot_em interface
+
+ 1. 新增 stock_bj_a_spot_em 接口,获取北交所 A 股行情数据
+
+1.6.11 add: add stock_sz_a_spot_em interface
+
+ 1. 新增 stock_sz_a_spot_em 接口,获取深证 A 股行情数据
+
+1.6.10 add: add stock_sh_a_spot_em interface
+
+ 1. 新增 stock_sh_a_spot_em 接口,获取上证 A 股行情数据
+
+1.6.9 fix: fix stock_zh_a_spot_em interface
+
+ 1. 修复 stock_zh_a_spot_em 接口,新增多个字段
+
+1.6.8 fix: fix futures_zh_spot interface
+
+ 1. 修复 futures_zh_spot 接口
+
+1.6.7 add: add futures_zh_realtime interface
+
+ 1. 新增 futures_zh_realtime 接口,获取期货的实时行情数据
+ 2. 新增 futures_symbol_mark 接口,获取新浪期货的所有品种标识
+
+1.6.6 fix: fix fund_etf_hist_sina interface
+
+ 1. 修复 fund_etf_hist_sina 接口,规范输出数据类型
+
+1.6.5 fix: fix stock_board_cons_ths interface
+
+ 1. 修复 stock_board_cons_ths 接口,修复获取链接的逻辑
+ 2. 给接口 stock_board_concept_name_ths 增加缓存功能
+
+1.6.4 fix: fix stock_info_a_code_name interface
+
+ 1. 修复 stock_info_a_code_name 接口,调整文档输出
+
+1.6.3 fix: fix stock_info_a_code_name and stock_info_sh_delist interface
+
+ 1. 修复 stock_info_a_code_name 接口,调整字段
+ 2. 修复 stock_info_sh_delist 接口,调整字段
+
+1.6.2 fix: fix macro_china_cpi interface
+
+ 1. 修复 macro_china_cpi 接口,输出按日期排序
+
+1.6.1 fix: fix stock_info_sh_name_code interface
+
+ 1. 修复 stock_info_sh_name_code 接口,字段对齐
+
+1.5.99 fix: fix stock_zh_a_hist_163 interface
+
+ 1. 修复 stock_zh_a_hist_163 接口,修改编码格式为 GBK 编码
+
+1.5.98 fix: fix news_cctv interface
+
+ 1. 修复 news_cctv 接口,适配 20220523 之后的新页面
+
+1.5.97 fix: fix stock_zh_a_hist interface
+
+ 1. 修复 stock_zh_a_hist 接口,除以日期设置的边界问题
+
+1.5.96 fix: fix macro_bank_usa_interest_rate interface
+
+ 1. 修复 macro_bank_usa_interest_rate 接口,规范输出数据格式且按时间排序
+
+1.5.95 fix: fix stock_zh_a_hist_163 interface
+
+ 1. 修复 stock_zh_a_hist_163 接口,增加编码支持
+
+1.5.94 add: add bond_cb_redeem_jsl interface
+
+ 1. 新增 bond_cb_redeem_jsl 接口,获取可转债强赎数据
+
+1.5.93 fix: fix stock_zh_a_hist interface
+
+ 1. 修复 stock_zh_a_hist 接口,对非交易日及停牌日期返回 pandas.DataFrame
+
+1.5.92 fix: fix rate_interbank interface
+
+ 1. 修复 rate_interbank 接口,修改函数签名及输出格式
+
+1.5.91 add: add bond_cb_index_jsl interface
+
+ 1. 新增 bond_cb_index_jsl 接口,获取集思录可转债等权指数数据
+
+1.5.90 fix: fix macro_china_bond_public interface
+
+ 1. 修复 macro_china_bond_public 接口
+
+1.5.89 fix: fix stock_info_sh_name_code interface
+
+ 1. 修复 stock_info_sh_name_code 接口
+
+1.5.88 fix: fix stock_board_concept_name_ths interface
+
+ 1. 修复 stock_board_concept_name_ths 接口,补充遗漏的概念板块
+
+1.5.87 fix: fix stock_tfp_em interface
+
+ 1. 修复 stock_tfp_em 接口
+
+1.5.86 fix: fix stock_us_fundamental interface
+
+ 1. 修复 stock_us_fundamental 接口的说明
+
+1.5.85 fix: fix stock_zh_a_hist interface
+
+ 1. 修复 stock_zh_a_hist 接口,直接返回指定时间段之间的数据
+
+1.5.84 fix: fix stock_three_report_em interface
+
+ 1. 修复 stock_balance_sheet_by_report_em 接口
+ 2. 修复 stock_balance_sheet_by_yearly_em 接口
+ 3. 修复 stock_profit_sheet_by_report_em 接口
+ 4. 修复 stock_profit_sheet_by_yearly_em 接口
+ 5. 修复 stock_profit_sheet_by_quarterly_em 接口
+ 6. 修复 stock_cash_flow_sheet_by_report_em 接口
+ 7. 修复 stock_cash_flow_sheet_by_yearly_em 接口
+
+1.5.83 fix: fix energy_oil_hist, energy_oil_detail interface
+
+ 1. 修复 energy_oil_hist 接口,按时间排序输出且规范数据输出格式
+ 2. 修复 energy_oil_detail 接口,规范数据输出格式
+
+1.5.82 add: add option_risk_indicator_sse interface
+
+ 1. 新增 option_risk_indicator_sse 接口,获取上海证券交易所-产品-股票期权-期权风险指标数据
+
+1.5.81 fix: fix macro_china_gdp_yearly interface
+
+ 1. 修复 macro_china_gdp_yearly 接口,数据输出格式为 pandas.DataFrame
+
+1.5.80 add: add stock_szse_sector_summary interface
+
+ 1. 新增 stock_szse_sector_summary 接口,获取深证证券交易所-总貌-股票行业成交数据
+
+1.5.79 add: add stock_szse_area_summary interface
+
+ 1. 新增 stock_szse_area_summary 接口,获取深证证券交易所-总貌-地区交易排序数据
+
+1.5.78 fix: fix stock_szse_summary interface
+
+ 1. 修复 stock_szse_summary 接口
+
+1.5.77 fix: fix remove numpy dependency
+
+ 1. 移除 numpy 依赖
+
+1.5.76 add: add news_report_time_baidu interface
+
+ 1. 新增 news_report_time_baidu 接口,获取财报发行时间
+
+1.5.75 fix: fix stock_financial_analysis_indicator interface
+
+ 1. 修复 stock_financial_analysis_indicator 接口的日期字段
+
+1.5.74 add: add news_trade_notify_suspend_baidu interface
+
+ 1. 新增 news_trade_notify_suspend_baidu 接口,获取 A 股及港股停复牌数据
+
+1.5.73 fix: fix stock_notice_report interface
+
+ 1. 修复 stock_notice_report 接口,添加日期参数
+
+1.5.72 add: add news_economic_baidu interface
+
+ 1. 新增 news_economic_baidu 接口,获取全球宏观事件数据
+
+1.5.71 fix: fix import path problem
+
+ 1. 修复 covid 接口中的路径问题
+
+1.5.70 fix: fix stock_zh_a_spot interface
+
+ 1. 修复 stock_zh_a_spot 中 pandas.DataFrame.append 警告
+
+1.5.69 fix: fix setup.py
+
+ 1. 修复 setup.py 文件
+
+1.5.68 fix: fix test function
+
+ 1. 修复 test_zipfile_func 函数
+
+1.5.67 add: add test function
+
+ 1. 新增测试函数,用于测试数据文件的路径
+
+1.5.66 fix: fix crypto_hist interface
+
+ 1. 修复 crypto_hist 接口,将部分数据存放到 data 文件夹读取,以提高访问稳定性及速度
+
+1.5.65 fix: fix stock_repurchase_em interface
+
+ 1. 修复 stock_repurchase_em 接口,获取股票回购-股票回购数据
+
+1.5.64 fix: fix stock_cash_flow_sheet_by_yearly_em interface
+
+ 1. 修复 stock_cash_flow_sheet_by_yearly_em 接口,获取现金流量表-按年度接口
+
+1.5.63 fix: fix import path problem
+
+ 1. 修复 JS 文件及数据文件导入问题,方便在本地调试代码
+
+1.5.62 add: add stock_cash_flow_sheet_by_quarterly_em interface
+
+ 1. 新增 stock_cash_flow_sheet_by_quarterly_em 接口,获取现金流量表-按单季度数据
+
+1.5.61 add: add stock_cash_flow_sheet_by_report_em interface
+
+ 1. 新增 stock_cash_flow_sheet_by_report_em 接口,获取现金流量表-按报告期数据
+
+1.5.60 fix: fix sw_index_second_spot interface
+
+ 1. 修复 sw_index_second_spot 接口,更新接口提交采纳数
+
+1.5.59 add: add stock_profit_sheet_by_yearly_em interface
+
+ 1. 新增 stock_profit_sheet_by_yearly_em 接口,获取利润表-按年度数据
+
+1.5.58 add: add stock_profit_sheet_by_quarterly_em interface
+
+ 1. 新增 stock_profit_sheet_by_quarterly_em 接口,获取利润表-按单季度数据
+
+1.5.57 add: add stock_profit_sheet_by_report_em interface
+
+ 1. 新增 stock_profit_sheet_by_report_em 接口,获取利润表-报告期数据
+
+1.5.56 add: add stock_balance_sheet_by_yearly_em interface
+
+ 1. 新增 stock_balance_sheet_by_yearly_em 接口,获取利润表-按年度数据
+
+1.5.55 add: add stock_balance_sheet_by_report_em interface
+
+ 1. 新增 stock_balance_sheet_by_report_em 接口,获取资产负债表-按报告期数据
+
+1.5.54 fix: fix stock_lrb_em interface
+
+ 1. 修复 stock_lrb_em 接口
+
+1.5.53 fix: fix stock_zcfz_em interface
+
+ 1. 修复 stock_zcfz_em 接口,重命名该接口并规范数据输出格式
+ 2. 修复 stock_lrb_em 接口,重命名该接口并规范数据输出格式
+ 3. 修复 stock_xjll_em 接口,重命名该接口并规范数据输出格式
+
+1.5.52 fix: fix stock_ggcg_em interface
+
+ 1. 修复 stock_ggcg_em 接口,重命名该接口、修改为东财的最新接口并规范数据输出
+
+1.5.51 fix: fix stock_zh_a_tick_163 interface
+
+ 1. 修复 stock_zh_a_tick_163 接口,读取 Excel 文件
+
+1.5.50 fix: fix covid_19_baidu interface
+
+ 1. 修复 covid_19_baidu 接口中的国内分省份详情和城市详情
+
+1.5.49 add: add stock_inner_trade_xq interface
+
+ 1. 新增 stock_inner_trade_xq 接口,获取股票的内部交易数据
+
+1.5.48 fix: fix futures_return_index_nh interface
+
+ 1. 修复 futures_return_index_nh 接口,重命名接口及规范数据输出格式
+ 2. 修复 futures_index_symbol_table_nh 接口,重名接口
+ 3. 修复 futures_price_index_nh 接口,重名接口
+
+1.5.47 fix: fix macro_china_lpr interface
+
+ 1. 修复 macro_china_lpr 接口,规范数据的输出格式
+
+1.5.46 fix: fix stock_yzxdr_em interface
+
+ 1. 修复 stock_yzxdr_em 接口,对接口进行重命名
+
+1.5.45 add: add stock_hot_deal_xq interface
+
+ 1. 新增 stock_hot_deal_xq 接口,获取雪球-沪深股市-热度排行榜-分享交易排行榜数据
+
+1.5.44 fix: fix futures_to_spot_czce interface
+
+ 1. 修复 futures_to_spot_czce 接口,直接读取 Excel 文件并规范输出的字段类型
+ 2. 修复 futures_delivery_czce 接口,直接读取 Excel 文件并规范输出的字段类型
+ 3. 修复 futures_delivery_match_czce 接口,直接读取 Excel 文件并规范输出的字段类型
+
+1.5.43 fix: fix stock_zt_pool_em interface
+
+ 1. 修复 stock_zt_pool_em 接口,获取所有股票的数据
+
+1.5.42 fix: fix stock_zt_pool_dtgc_em interface
+
+ 1. 修复 stock_zt_pool_dtgc_em 接口,获取所有股票的数据
+
+1.5.41 fix: fix stock_margin_underlying_info_szse interface
+
+ 1. 修复 stock_margin_underlying_info_szse 接口,利用 pandas.concate 替换 pandas.DataFrame.append 方法
+
+1.5.40 fix: fix js_news interface
+
+ 1. 修复 js_news 接口,规范输出数据的格式
+
+1.5.39 add: add stock_comment_detail_scrd_desire_daily_em interface
+
+ 1. 新增 stock_comment_detail_scrd_desire_daily_em 接口,获取日度市场参与意愿数据数据
+
+1.5.38 add: add stock_comment_detail_scrd_cost_em interface
+
+ 1. 新增 stock_comment_detail_scrd_cost_em 接口,获取市场成本数据
+
1.5.37 add: add stock_comment_detail_scrd_desire_em interface
1. 新增 stock_comment_detail_scrd_desire_em 接口,获取市场参与意愿数据
@@ -108,9 +469,9 @@
1. 修复 stock_info_sh_delist 接口
-1.5.15 fix: fix bond_cov_jsl interface
+1.5.15 fix: fix bond_cb_jsl interface
- 1. 修复 bond_cov_jsl 接口
+ 1. 修复 bond_cb_jsl 接口
1.5.14 add: add macro_china_bdti_index interface
@@ -170,7 +531,7 @@
1. 新增 macro_china_agricultural_product 接口,获取农产品批发价格总指数数据
1.4.99 add: add macro_china_vegetable_basket interface
-
+
1. 新增 macro_china_vegetable_basket 接口,获取菜篮子产品批发价格指数数据
1.4.98 fix: fix stock_board_industry_hist_em interface
@@ -199,7 +560,7 @@
1.4.92 add: add stock_lhb_hyyyb_em interface
- 1. 新增 stock_lhb_hyyyb_em 接口,获取东方财富网-数据中心-龙虎榜单-每日活跃营业部数据
+ 1. 新增 stock_lhb_hyyyb_em 接口,获取东方财富网-数据中心-龙虎榜单-每日活跃营业部数据
1.4.91 fix: fix macro_china_new_financial_credit interface
@@ -214,7 +575,7 @@
1. 修复 stock_us_hist 接口,结果数据根据日期排序
1.4.88 fix: fix fund_new_found_em interface
-
+
1. 修复 fund_em_new_found 接口命名为 fund_new_found_em 接口
1.4.87 add: add fund_portfolio_industry_allocation_em interface
@@ -334,7 +695,7 @@
1. 修复 get_dce_daily 接口的索引问题
1.4.60 fix: fix stock_zh_a_hist_163 interface
-
+
1. 修复 stock_zh_a_hist_163 接口的冗余变量问题
1.4.59 add: add stock_zh_a_hist_163 interface
@@ -411,6 +772,172 @@
## 版本更新说明
+1.6.21 fix: fix baidu_search_index interface
+
+1.6.20 fix: fix stock_board_industry_name_em and code_id_map_em interface
+
+1.6.19 fix: fix stock_comment_detail_zlkp_jgcyd_em interface
+
+1.6.18 fix: fix stock_zh_a_spot_em interface
+
+1.6.17 fix: fix stock_new_a_spot_em interface
+
+1.6.16 fix: fix baidu_search_index interface
+
+1.6.15 fix: fix bond_zh_cov_info interface
+
+1.6.14 fix: fix stock_hsgt_board_rank_em interface
+
+1.6.13 add: add stock_new_a_spot_em interface
+
+1.6.12 add: add stock_bj_a_spot_em interface
+
+1.6.11 add: add stock_sz_a_spot_em interface
+
+1.6.10 add: add stock_sh_a_spot_em interface
+
+1.6.9 fix: fix stock_zh_a_spot_em interface
+
+1.6.8 fix: fix futures_zh_spot interface
+
+1.6.7 add: add futures_zh_realtime interface
+
+1.6.6 fix: fix fund_etf_hist_sina interface
+
+1.6.5 fix: fix stock_board_cons_ths interface
+
+1.6.4 fix: fix stock_info_a_code_name interface
+
+1.6.3 fix: fix stock_info_a_code_name and stock_info_sh_delist interface
+
+1.6.2 fix: fix macro_china_cpi interface
+
+1.6.1 fix: fix stock_info_sh_name_code interface
+
+1.5.99 fix: fix stock_zh_a_hist_163 interface
+
+1.5.98 fix: fix news_cctv interface
+
+1.5.97 fix: fix stock_zh_a_hist interface
+
+1.5.96 fix: fix macro_bank_usa_interest_rate interface
+
+1.5.95 fix: fix stock_zh_a_hist_163 interface
+
+1.5.94 add: add bond_cb_redeem_jsl interface
+
+1.5.93 fix: fix stock_zh_a_hist interface
+
+1.5.92 fix: fix rate_interbank interface
+
+1.5.91 add: add bond_cb_index_jsl interface
+
+1.5.90 fix: fix macro_china_bond_public interface
+
+1.5.89 fix: fix stock_info_sh_name_code interface
+
+1.5.88 fix: fix stock_board_concept_name_ths interface
+
+1.5.87 fix: fix stock_tfp_em interface
+
+1.5.86 fix: fix stock_us_fundamental interface
+
+1.5.85 fix: fix stock_zh_a_hist interface
+
+1.5.84 fix: fix stock_three_report_em interface
+
+1.5.83 fix: fix energy_oil_hist, energy_oil_detail interface
+
+1.5.82 add: add option_risk_indicator_sse interface
+
+1.5.81 fix: fix macro_china_gdp_yearly interface
+
+1.5.80 add: add stock_szse_sector_summary interface
+
+1.5.79 add: add stock_szse_area_summary interface
+
+1.5.78 fix: fix stock_szse_summary interface
+
+1.5.77 fix: fix remove numpy dependency
+
+1.5.76 add: add news_report_time_baidu interface
+
+1.5.75 fix: fix stock_financial_analysis_indicator interface
+
+1.5.74 add: add news_trade_notify_suspend_baidu interface
+
+1.5.73 fix: fix stock_notice_report interface
+
+1.5.72 add: add news_economic_baidu interface
+
+1.5.71 fix: fix import path problem
+
+1.5.70 fix: fix stock_zh_a_spot interface
+
+1.5.69 fix: fix setup.py
+
+1.5.68 fix: fix test function
+
+1.5.67 add: add test function
+
+1.5.66 fix: fix crypto_hist interface
+
+1.5.65 fix: fix stock_repurchase_em interface
+
+1.5.64 fix: fix stock_cash_flow_sheet_by_yearly_em interface
+
+1.5.63 fix: fix import path problem
+
+1.5.62 add: add stock_cash_flow_sheet_by_quarterly_em interface
+
+1.5.61 add: add stock_cash_flow_sheet_by_report_em interface
+
+1.5.60 fix: fix sw_index_second_spot interface
+
+1.5.59 add: add stock_profit_sheet_by_yearly_em interface
+
+1.5.58 add: add stock_profit_sheet_by_quarterly_em interface
+
+1.5.57 add: add stock_profit_sheet_by_report_em interface
+
+1.5.56 add: add stock_balance_sheet_by_yearly_em interface
+
+1.5.55 add: add stock_balance_sheet_by_report_em interface
+
+1.5.54 fix: fix stock_lrb_em interface
+
+1.5.53 fix: fix stock_zcfz_em interface
+
+1.5.52 fix: fix stock_ggcg_em interface
+
+1.5.51 fix: fix stock_zh_a_tick_163 interface
+
+1.5.50 fix: fix covid_19_baidu interface
+
+1.5.49 add: add stock_inner_trade_xq interface
+
+1.5.48 fix: fix futures_return_index_nh interface
+
+1.5.47 fix: fix macro_china_lpr interface
+
+1.5.46 fix: fix stock_yzxdr_em interface
+
+1.5.45 add: add stock_hot_deal_xq interface
+
+1.5.44 fix: fix futures_to_spot_czce interface
+
+1.5.43 fix: fix stock_zt_pool_em interface
+
+1.5.42 fix: fix stock_zt_pool_dtgc_em interface
+
+1.5.41 fix: fix stock_margin_underlying_info_szse interface
+
+1.5.40 fix: fix js_news interface
+
+1.5.39 add: add stock_comment_detail_scrd_desire_daily_em interface
+
+1.5.38 add: add stock_comment_detail_scrd_cost_em interface
+
1.5.37 add: add stock_comment_detail_scrd_desire_em interface
1.5.36 add: add stock_comment_detail_scrd_focus_em interface
@@ -455,7 +982,7 @@
1.5.16 fix: fix stock_info_sh_delist interface
-1.5.15 fix: fix bond_cov_jsl interface
+1.5.15 fix: fix bond_cb_jsl interface
1.5.14 add: add macro_china_bdti_index interface