summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5522fe079958..c90f2638a536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-django-sortedm2m
pkgdesc = A transparent sorted ManyToMany field for django
- pkgver = 3.0.2
+ pkgver = 3.1.1
pkgrel = 1
url = https://github.com/jazzband/django-sortedm2m
arch = any
license = BSD
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-django
- source = https://github.com/jazzband/django-sortedm2m/archive/refs/tags/3.0.2.tar.gz
- sha256sums = f14b86ab4f610de42937c11058664b2f8e9b722ae42f0197c448125eb9895777
+ source = python-django-sortedm2m-3.1.1::https://github.com/jazzband/django-sortedm2m/archive/refs/tags/3.1.1.tar.gz
+ sha256sums = 06591bbd1a531b25f838fd3a4ce93dfe9a527982dc82015530b1fc29655ed80c
pkgname = python-django-sortedm2m
diff --git a/PKGBUILD b/PKGBUILD
index 1924d5d4c529..3cffe23d043f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,23 @@
# Contributor: David McInnis <davidm@eagles.ewu.edu>
pkgname="python-django-sortedm2m"
-pkgver=3.0.2
+pkgver=3.1.1
pkgrel=1
pkgdesc="A transparent sorted ManyToMany field for django"
url="https://github.com/jazzband/django-sortedm2m"
depends=("python-django")
-makedepends=("python-setuptools")
+makedepends=("python-setuptools" "python-build" "python-installer" "python-wheel")
license=("BSD")
arch=("any")
-source=("https://github.com/jazzband/django-sortedm2m/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=("f14b86ab4f610de42937c11058664b2f8e9b722ae42f0197c448125eb9895777")
+source=("$pkgname-$pkgver::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('06591bbd1a531b25f838fd3a4ce93dfe9a527982dc82015530b1fc29655ed80c')
+
+build(){
+ cd "django-sortedm2m-$pkgver"
+ python -m build --wheel --no-isolation
+}
package(){
cd "django-sortedm2m-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}