summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1924d5d4c529..3cffe23d043f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,23 @@
# Contributor: David McInnis <davidm@eagles.ewu.edu>
pkgname="python-django-sortedm2m"
-pkgver=3.0.2
+pkgver=3.1.1
pkgrel=1
pkgdesc="A transparent sorted ManyToMany field for django"
url="https://github.com/jazzband/django-sortedm2m"
depends=("python-django")
-makedepends=("python-setuptools")
+makedepends=("python-setuptools" "python-build" "python-installer" "python-wheel")
license=("BSD")
arch=("any")
-source=("https://github.com/jazzband/django-sortedm2m/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=("f14b86ab4f610de42937c11058664b2f8e9b722ae42f0197c448125eb9895777")
+source=("$pkgname-$pkgver::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('06591bbd1a531b25f838fd3a4ce93dfe9a527982dc82015530b1fc29655ed80c')
+
+build(){
+ cd "django-sortedm2m-$pkgver"
+ python -m build --wheel --no-isolation
+}
package(){
cd "django-sortedm2m-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}