summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD11
3 files changed, 7 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff6a0699fe24..9cdded98592f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = python-download-npo
pkgdesc = Download videos from the Dutch npo.nl site.
pkgver = 2.9.1
- pkgrel = 1
+ pkgrel = 2
url = http://arp242.net/code/download-npo
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python
depends = hicolor-icon-theme
optdepends = tk: Graphical frontend
optdepends = libmms: Download older MMS videos
optdepends = python-mutagen: Update metada of downloaded files
source = https://github.com/Carpetsmoker/download-npo/archive/version-2.9.1.tar.gz
- source = LICENSE
sha256sums = b7a69f55b31750f1f12842cbb4f133442986abba4b3a2533a522d6c5af42bc68
- sha256sums = 6976e1dd59a0e0fb1b0e32a8a53eb6502485550be941560bcacb78901e5cd096
pkgname = python-download-npo
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 5d6c39ad625a..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-The MIT License (MIT)
-
-Copyright © 2012-2017 Martin Tournoij
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to
-deal in the Software without restriction, including without limitation the
-rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
-sell copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-The software is provided "as is", without warranty of any kind, express or
-implied, including but not limited to the warranties of merchantability,
-fitness for a particular purpose and noninfringement. In no event shall the
-authors or copyright holders be liable for any claim, damages or other
-liability, whether in an action of contract, tort or otherwise, arising
-from, out of or in connection with the software or the use or other dealings
-in the software.
diff --git a/PKGBUILD b/PKGBUILD
index 7736c9e97d1e..d3a442fdcd96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,18 @@
pkgname=python-download-npo
_module='download-npo'
pkgver=2.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="Download videos from the Dutch npo.nl site."
url="http://arp242.net/code/download-npo"
depends=('python' 'hicolor-icon-theme')
+makedepends=('python-setuptools')
optdepends=('tk: Graphical frontend'
'libmms: Download older MMS videos'
'python-mutagen: Update metada of downloaded files')
license=('MIT')
arch=('any')
-source=("https://github.com/Carpetsmoker/download-npo/archive/version-${pkgver}.tar.gz"
- 'LICENSE')
-sha256sums=('b7a69f55b31750f1f12842cbb4f133442986abba4b3a2533a522d6c5af42bc68'
- '6976e1dd59a0e0fb1b0e32a8a53eb6502485550be941560bcacb78901e5cd096')
+source=("https://github.com/Carpetsmoker/download-npo/archive/version-${pkgver}.tar.gz")
+sha256sums=('b7a69f55b31750f1f12842cbb4f133442986abba4b3a2533a522d6c5af42bc68')
build() {
cd "$srcdir/${_module}-version-${pkgver}"
@@ -22,7 +21,7 @@ build() {
}
package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "$srcdir/${_module}-version-${pkgver}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python setup.py install --root="$pkgdir" --optimize=1
}