summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7736c9e97d1e..d3a442fdcd96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,18 @@
pkgname=python-download-npo
_module='download-npo'
pkgver=2.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="Download videos from the Dutch npo.nl site."
url="http://arp242.net/code/download-npo"
depends=('python' 'hicolor-icon-theme')
+makedepends=('python-setuptools')
optdepends=('tk: Graphical frontend'
'libmms: Download older MMS videos'
'python-mutagen: Update metada of downloaded files')
license=('MIT')
arch=('any')
-source=("https://github.com/Carpetsmoker/download-npo/archive/version-${pkgver}.tar.gz"
- 'LICENSE')
-sha256sums=('b7a69f55b31750f1f12842cbb4f133442986abba4b3a2533a522d6c5af42bc68'
- '6976e1dd59a0e0fb1b0e32a8a53eb6502485550be941560bcacb78901e5cd096')
+source=("https://github.com/Carpetsmoker/download-npo/archive/version-${pkgver}.tar.gz")
+sha256sums=('b7a69f55b31750f1f12842cbb4f133442986abba4b3a2533a522d6c5af42bc68')
build() {
cd "$srcdir/${_module}-version-${pkgver}"
@@ -22,7 +21,7 @@ build() {
}
package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "$srcdir/${_module}-version-${pkgver}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python setup.py install --root="$pkgdir" --optimize=1
}