summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rwxr-xr-x.gitignore10
-rw-r--r--[-rwxr-xr-x]PKGBUILD23
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8e7200e7e40..b387eb6fc50f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-frccontrol-git
pkgdesc = Provides SciPy wrappers that ease development of state-space models for the FIRST Robotics Competition.
- pkgver = 2023.13
+ pkgver = 2023.31
pkgrel = 1
url = https://github.com/calcmogul/frccontrol.git
arch = x86_64
license = BSD
+ makedepends = python-tox
depends = python-matplotlib
depends = python-numpy
depends = python-scipy
- source = python-frccontrol-git::git+https://github.com/calcmogul/frccontrol.git
+ source = git+https://github.com/calcmogul/frccontrol.git
md5sums = SKIP
pkgname = python-frccontrol-git
diff --git a/.gitignore b/.gitignore
index f20e8d17a47b..1ee3703bd032 100755
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,4 @@
-src
-pkg
-*.tar.xz
-*.tar.gz
-*.tar
-python-frccontrol-git/
+frccontrol/
+src/
+pkg/
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 7179d0f51a25..a69b36064989 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Modelmat <modelmat@outlook.com.au>
pkgname=python-frccontrol-git
-pkgver=2023.13
+pkgver=2023.31
pkgrel=1
pkgdesc="Provides SciPy wrappers that ease development of state-space models for the FIRST Robotics Competition."
arch=("x86_64")
url="https://github.com/calcmogul/frccontrol.git"
license=("BSD")
depends=("python-matplotlib" "python-numpy" "python-scipy")
-source=(${pkgname}::"git+https://github.com/calcmogul/frccontrol.git")
+makedepends=('python-tox')
+source=(git+https://github.com/calcmogul/frccontrol.git)
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/frccontrol"
year=$(date +%Y)
echo $year.$(git rev-list --count --after="main@{$(($year - 1))-01-01}" main)
}
-check() {
- cd "${srcdir}/${pkgname}"
- python setup.py test
+build() {
+ cd "${srcdir}/frccontrol"
+ python -m build --wheel
}
-build() {
- cd "${srcdir}/${pkgname}"
- python setup.py build
+check() {
+ cd "${srcdir}/frccontrol"
+ tox
}
package() {
- cd "${srcdir}/${pkgname}"
- python setup.py install --root="${pkgdir}" --skip-build
+ cd "${srcdir}/frccontrol"
+ pip install dist/frccontrol-*.whl --no-deps --root ${pkgdir} --ignore-installed
}