summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9caed6ceab90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-httpolice
+ pkgdesc = Validator for HTTP
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/vfaronov/httpolice
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-httpolice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd536e009a72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# PKGBUILD generated by pipman
+# Python package author: Vasiliy Faronov <vfaronov@gmail.com>
+pkgname=python-httpolice
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Validator for HTTP"
+arch=(any)
+url="https://github.com/vfaronov/httpolice"
+license=(MIT)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="httpolice" httpolice
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.5/site-packages/
+ cp -r $srcdir/httpolice/* $pkgdir/usr/lib/python3.5/site-packages/
+} \ No newline at end of file