summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3b66dd60bd2..9adb0f12cd87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = python-requests-gpgauthlib
pkgdesc = A GPGAuth Client in Python
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/liip/requests_gpgauthlib
arch = any
license = GPL3
makedepends = python-setuptools
+ makedepends = python-pytest
+ makedepends = python-tests
+ makedepends = python-mock
+ makedepends = python-requests-mock
depends = python
- source = https://github.com/liip/requests_gpgauthlib/archive/0.1.2.tar.gz
+ depends = python-gnupg
+ depends = python-requests
+ source = https://github.com/liip/requests_gpgauthlib/archive/0.1.2/python-requests-gpgauthlib-0.1.2.tar.gz
b2sums = ee17a073377f7b413bb9377b04ba99188794cf67433c60d087f667bd89e479e470f6a1f3e4d564cd90981300a3734f68d14cb66e25e20828ff27c7f17386cbf6
pkgname = python-requests-gpgauthlib
diff --git a/PKGBUILD b/PKGBUILD
index 2117443377ca..dda651bbb01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=python-requests-gpgauthlib
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='A GPGAuth Client in Python'
arch=('any')
url='https://github.com/liip/requests_gpgauthlib'
license=('GPL3')
-depends=('python')
-makedepends=('python-setuptools')
-source=("https://github.com/liip/requests_gpgauthlib/archive/${pkgver}.tar.gz")
+depends=('python' 'python-gnupg' 'python-requests')
+makedepends=('python-setuptools' 'python-pytest' 'python-tests' 'python-mock' 'python-requests-mock')
+source=("https://github.com/liip/requests_gpgauthlib/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
b2sums=('ee17a073377f7b413bb9377b04ba99188794cf67433c60d087f667bd89e479e470f6a1f3e4d564cd90981300a3734f68d14cb66e25e20828ff27c7f17386cbf6')
build() {
@@ -17,6 +17,12 @@ build() {
python setup.py build
}
+# fails atm
+# check() {
+# cd requests_gpgauthlib-${pkgver}
+# python -m pytest
+# }
+
package() {
cd requests_gpgauthlib-${pkgver}
NO_THIRD_PARTY=true python setup.py install --skip-build --root="${pkgdir}" --optimize=1