summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md33
-rw-r--r--PKGBUILD7
3 files changed, 40 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b28d30dbbf0d..ec39a18abb49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tcod
pkgdesc = High-performance Python port of libtcod
- pkgver = 13.7.0
+ pkgver = 13.8.1
pkgrel = 1
url = https://github.com/libtcod/python-tcod
changelog = CHANGELOG.md
@@ -19,8 +19,8 @@ pkgbase = python-tcod
depends = python-numpy
depends = python-typing_extensions
depends = sdl2
- source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.7.0?signed
- source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.21.0?signed
+ source = python-tcod::git+https://github.com/libtcod/python-tcod#tag=13.8.1?signed
+ source = libtcod::git+https://github.com/libtcod/libtcod#tag=1.22.3?signed
validpgpkeys = 9EF1E80F3817BC043097A7C15814977902B194CC
sha256sums = SKIP
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 0874c558e4a6..5590ccb35c51 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,39 @@ This project adheres to [Semantic Versioning](https://semver.org/) since version
## [Unreleased]
+## [13.8.1] - 2022-09-23
+### Fixed
+- `EventDispatch` was missing new event names.
+
+## [13.8.0] - 2022-09-22
+### Added
+- Ported SDL2 joystick handing as `tcod.sdl.joystick`.
+- New joystick related events.
+
+### Changed
+- Using `libtcod 1.22.3`.
+- Bundle `SDL 2.24.0` on Windows and MacOS.
+
+### Deprecated
+- Renderers other than `tcod.RENDERER_SDL2` are now discouraged.
+
+### Fixed
+- Fixed double present bug in non-context flush functions.
+ This was affecting performance and also caused a screen flicker whenever the global fade color was active.
+- Fixed the parsing of SDL 2.24.0 headers on Windows.
+
+## [13.7.0] - 2022-08-07
+### Added
+- You can new use `SDLConsoleRender.atlas` to access the `SDLTilesetAtlas` used to create it.
+ [#121](https://github.com/libtcod/python-tcod/issues/121)
+
+### Fixed
+- Fixed the parsing of SDL 2.0.22 headers. Specifically `SDL_FLT_EPSILON`.
+
+## [13.6.2] - 2022-05-02
+### Fixed
+- SDL renderers were ignoring tiles where only the background red channel was changed.
+
## [13.6.1] - 2022-03-29
### Changed
- The SDL2 renderer has had a major performance update when compiled with SDL 2.0.18.
diff --git a/PKGBUILD b/PKGBUILD
index 70ab82cafd53..96f4aa77971a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.7.0
+pkgver=13.8.1
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
@@ -18,7 +18,7 @@ makedepends=(
changelog=CHANGELOG.md
source=(
"$pkgname::git+$url#tag=$pkgver?signed"
- 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.21.0?signed')
+ 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.22.3?signed')
sha256sums=('SKIP'
'SKIP')
validpgpkeys=('9EF1E80F3817BC043097A7C15814977902B194CC') # Kyle Benesch @ GitHub
@@ -28,11 +28,12 @@ prepare() {
git submodule init
git config submodule.libtcod.url "$srcdir/libtcod"
git submodule update
+ sed -i '/setuptools/s/==/>=/' pyproject.toml requirements.txt
}
build() {
cd "$pkgname"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
make -C docs man
}