summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70ab82cafd53..96f4aa77971a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.7.0
+pkgver=13.8.1
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
@@ -18,7 +18,7 @@ makedepends=(
changelog=CHANGELOG.md
source=(
"$pkgname::git+$url#tag=$pkgver?signed"
- 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.21.0?signed')
+ 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.22.3?signed')
sha256sums=('SKIP'
'SKIP')
validpgpkeys=('9EF1E80F3817BC043097A7C15814977902B194CC') # Kyle Benesch @ GitHub
@@ -28,11 +28,12 @@ prepare() {
git submodule init
git config submodule.libtcod.url "$srcdir/libtcod"
git submodule update
+ sed -i '/setuptools/s/==/>=/' pyproject.toml requirements.txt
}
build() {
cd "$pkgname"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
make -C docs man
}