summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD65
2 files changed, 26 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f1e532d25cb..9e816ed5f84f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python2-notify
- pkgdesc = Python bindings for lib
+ pkgdesc = Python bindings for libnotify
pkgver = 0.1.1
pkgrel = 14
- url = https://web.archive.org/web/20210304223822//news/index.php
+ url = http://www.galago-project.org/
arch = i686
arch = x86_64
license = GPL
- makedepends = ipfs-dlagent
makedepends = python2
depends = pygtk>=2.22.0
depends = libnotify>=0.7.1
conflicts = python-notify<=0.1.1-11
replaces = python-notify<=0.1.1-11
- source = notify-python-0.1.1::ipfs://QmUrkNKgBrRJ1ha4Yv7Mh7RCvTq1kRQWEWDLZmuLmcVLvU
+ source = https://galago-project.org/files/releases/source/notify-python/notify-python-0.1.1.tar.gz
source = libnotify07.patch
source = notify-python-0.1.1-fix-GTK-symbols.patch
sha512sums = f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf
diff --git a/PKGBUILD b/PKGBUILD
index 4a5ecf2838f2..b279835ed44d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,44 @@
-# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
-# Contributor: Jonathon Fernyhough <jonathon "m2x +dotdev>
+# Maintainer: Jonathon Fernyhough <jonathon "m2x +dotdev>
# Contributor: Angel Velasquez <angvp@archlinux.org>
-_py="python2"
-_pkg="notify"
-pkgname="${_py}-${_pkg}"
+pkgname=python2-notify
pkgver=0.1.1
pkgrel=14
-pkgdesc="Python bindings for lib${pkg}"
+pkgdesc="Python bindings for libnotify"
arch=('i686' 'x86_64')
-_url="http://www.galago-project.org/"
-url="https://web.archive.org/web/20210304223822/${url}/news/index.php"
+url="http://www.galago-project.org/"
license=('GPL')
-depends=(
- 'pygtk>=2.22.0'
- "lib${_pkg}>=0.7.1"
-)
-makedepends=(
- "ipfs-dlagent"
- "${_py}"
-)
-conflicts=("python-${_pkg}<=0.1.1-11")
-replaces=("python-${_pkg}<=0.1.1-11")
-_ipfs_msg=("Could not find %u. Manually download it to \"$(pwd)\", "
- "or set up an ipfs:// DLAGENT in /etc/makepkg.conf.\"; exit 1")
-DLAGENTS+=(
- "ipfs:///usr/bin/echo '${_ipfs_msg[*]}'"
-)
-source=(
- "${_pkg}-python-${pkgver}::ipfs://QmUrkNKgBrRJ1ha4Yv7Mh7RCvTq1kRQWEWDLZmuLmcVLvU"
- # "${url}/files/releases/source/${_pkg}-python/${_pkg}-python-${pkgver}.tar.gz"
- "lib${_pkg}07.patch"
- "${_pkg}-python-0.1.1-fix-GTK-symbols.patch")
-sha512sums=(
- 'f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf'
- 'd8c9a829d9255c0e971f00f7ef0f337207f94cd89f67bc657f0bcc2dc18a50b138924e2f9ef878daad2372256f7656064071f7a7324292700044c93e990f17fc'
- 'a5f9f04b080425114950aaa7fc2e68ff3e32d092cd0f7a9ef212a37d8056e4a2d438d075921e66be541bbdcadb4602c14e5bb7443e7455dc7ebc923c4dbd0961')
+depends=('pygtk>=2.22.0' 'libnotify>=0.7.1')
+makedepends=('python2')
+conflicts=('python-notify<=0.1.1-11')
+replaces=('python-notify<=0.1.1-11')
+source=(https://galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz
+ libnotify07.patch
+ notify-python-0.1.1-fix-GTK-symbols.patch)
+sha512sums=('f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf'
+ 'd8c9a829d9255c0e971f00f7ef0f337207f94cd89f67bc657f0bcc2dc18a50b138924e2f9ef878daad2372256f7656064071f7a7324292700044c93e990f17fc'
+ 'a5f9f04b080425114950aaa7fc2e68ff3e32d092cd0f7a9ef212a37d8056e4a2d438d075921e66be541bbdcadb4602c14e5bb7443e7455dc7ebc923c4dbd0961')
prepare() {
- cd "${_pkg}-python-${pkgver}"
+ cd notify-python-$pkgver
- patch -Np1 -i "../lib${_pkg}07.patch"
- patch -Np1 -i "../${_pkg}-python-0.1.1-fix-GTK-symbols.patch"
+ patch -Np1 -i ../libnotify07.patch
+ patch -Np1 -i ../notify-python-0.1.1-fix-GTK-symbols.patch
./configure --prefix=/usr
- # WARNING - we touch src/pynotify.override in build because
- # upstream did not rebuild pynotify.c from the input definitions,
- # this forces pynotify.c to be regenerated, at some point this can be removed
- touch "src/py${_pkg}.override"
+ # WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
+ # from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
+ touch src/pynotify.override
}
build() {
- cd "${_pkg}-python-${pkgver}"
+ cd notify-python-$pkgver
make clean
make CFLAGS+=" -fcommon"
}
package() {
- cd "${_pkg}-python-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd notify-python-$pkgver
+ make DESTDIR="$pkgdir" install
}