summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--python2.patch27
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5af51f4ee67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-svnplot
+ pkgdesc = SVNPlot generates graphs similar to StatSVN
+ pkgver = 0.8.6
+ pkgrel = 1
+ url = https://bitbucket.org/nitinbhide/svnplot/wiki/Home
+ arch = any
+ license = BSD
+ makedepends = dos2unix
+ depends = python2-numpy
+ depends = python2-matplotlib
+ depends = python2-pysvn
+ source = https://bitbucket.org/nitinbhide/svnplot/downloads/SVNPlot-0.8.6.zip
+ source = python2.patch
+ md5sums = 6c0118bad51dc8072bc4641e84b3af6d
+ md5sums = 42335334fe6ad000587be8768124ed45
+
+pkgname = python2-svnplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4c6cfed1205
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: antoniogmc <AT> gmail <DOT> com
+
+pkgname=python2-svnplot
+_pkgname=SVNPlot
+pkgver=0.8.6
+pkgrel=1
+pkgdesc="SVNPlot generates graphs similar to StatSVN"
+arch=('any')
+url="https://bitbucket.org/nitinbhide/svnplot/wiki/Home"
+license=('BSD')
+depends=('python2-numpy' 'python2-matplotlib' 'python2-pysvn')
+makedepends=('dos2unix')
+source=(https://bitbucket.org/nitinbhide/svnplot/downloads/${_pkgname}-${pkgver}.zip python2.patch)
+md5sums=('6c0118bad51dc8072bc4641e84b3af6d'
+ '42335334fe6ad000587be8768124ed45')
+
+package() {
+ cd "$srcdir"/$_pkgname-${pkgver}
+
+ patch -Np1 -i $srcdir/python2.patch
+
+ dos2unix *.py
+
+ python2 setup.py install --root "$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..1ec6276ba250
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,27 @@
+diff -urN SVNPlot-0.8.1.orig/svngraphs.py SVNPlot-0.8.1/svngraphs.py
+--- SVNPlot-0.8.1.orig/svngraphs.py 2014-05-13 22:07:10.000000000 +0200
++++ SVNPlot-0.8.1/svngraphs.py 2014-10-02 21:56:04.689700950 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python2
+ '''
+ svngraphs.py
+ Copyright (C) 2009 Nitin Bhide (nitinbhide@gmail.com)
+diff -urN SVNPlot-0.8.1.orig/svnlog2sqlite.py SVNPlot-0.8.1/svnlog2sqlite.py
+--- SVNPlot-0.8.1.orig/svnlog2sqlite.py 2014-04-30 16:46:04.000000000 +0200
++++ SVNPlot-0.8.1/svnlog2sqlite.py 2014-10-02 21:56:14.586342309 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python2
+ '''
+ svnlog2sqlite.py
+ Copyright (C) 2009 Nitin Bhide (nitinbhide@gmail.com)
+diff -urN SVNPlot-0.8.1.orig/svnplotjs.py SVNPlot-0.8.1/svnplotjs.py
+--- SVNPlot-0.8.1.orig/svnplotjs.py 2014-04-30 16:46:06.000000000 +0200
++++ SVNPlot-0.8.1/svnplotjs.py 2014-10-02 21:56:36.276285637 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python2
+ '''
+ svnplot-js.py
+ Copyright (C) 2009 Nitin Bhide (nitinbhide@gmail.com)