summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4c6cfed1205
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: antoniogmc <AT> gmail <DOT> com
+
+pkgname=python2-svnplot
+_pkgname=SVNPlot
+pkgver=0.8.6
+pkgrel=1
+pkgdesc="SVNPlot generates graphs similar to StatSVN"
+arch=('any')
+url="https://bitbucket.org/nitinbhide/svnplot/wiki/Home"
+license=('BSD')
+depends=('python2-numpy' 'python2-matplotlib' 'python2-pysvn')
+makedepends=('dos2unix')
+source=(https://bitbucket.org/nitinbhide/svnplot/downloads/${_pkgname}-${pkgver}.zip python2.patch)
+md5sums=('6c0118bad51dc8072bc4641e84b3af6d'
+ '42335334fe6ad000587be8768124ed45')
+
+package() {
+ cd "$srcdir"/$_pkgname-${pkgver}
+
+ patch -Np1 -i $srcdir/python2.patch
+
+ dos2unix *.py
+
+ python2 setup.py install --root "$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: