summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix-musicbrainz.patch12
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c15b785d07b..f3a362db36cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ripit
pkgdesc = Command line tool to rip tracks from audio cds and encode them
pkgver = 4.0.0_rc_20161009
- pkgrel = 7
+ pkgrel = 8
url = https://www.ripit.pl
arch = any
license = GPL
@@ -22,6 +22,8 @@ pkgbase = ripit
optdepends = perl-musicbrainz-discid: Tagging (Musicbrainz.org)
backup = etc/ripit/config
source = https://www.ripit.pl/ripit/ripit-4.0.0_rc_20161009.tar.bz2
+ source = fix-musicbrainz.patch
sha256sums = 2434ec6e5b8044de9b081cb7a0c713e52a09443270c6abe9f415a006ecda0c66
+ sha256sums = 1ecb55c3a87db018b7dc74083fd48a3333b0b42b9771095cb84b68c1e30122f4
pkgname = ripit
diff --git a/PKGBUILD b/PKGBUILD
index df343aa24b8c..bd65896727a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname='ripit'
pkgver='4.0.0_rc_20161009'
-pkgrel='7'
+pkgrel='8'
pkgdesc='Command line tool to rip tracks from audio cds and encode them'
arch=('any')
url='https://www.ripit.pl'
@@ -23,8 +23,10 @@ optdepends=(
'perl-webservice-musicbrainz: Tagging (Musicbrainz.org)'
'perl-musicbrainz-discid: Tagging (Musicbrainz.org)'
)
-source=("https://www.ripit.pl/ripit/ripit-${pkgver}.tar.bz2")
-sha256sums=('2434ec6e5b8044de9b081cb7a0c713e52a09443270c6abe9f415a006ecda0c66')
+source=("https://www.ripit.pl/ripit/ripit-${pkgver}.tar.bz2"
+ "fix-musicbrainz.patch")
+sha256sums=('2434ec6e5b8044de9b081cb7a0c713e52a09443270c6abe9f415a006ecda0c66'
+ '1ecb55c3a87db018b7dc74083fd48a3333b0b42b9771095cb84b68c1e30122f4')
backup=('etc/ripit/config')
prepare() {
@@ -32,6 +34,7 @@ prepare() {
# replace freedb with gnudb
sed 's/CDDBHOST=freedb.org/CDDBHOST=gnudb.org/' -i config
sed 's/mirror=freedb/mirror=gnudb/' -i config
+ patch -Np1 -i ../fix-musicbrainz.patch
}
package() {
diff --git a/fix-musicbrainz.patch b/fix-musicbrainz.patch
new file mode 100644
index 000000000000..777b5b108148
--- /dev/null
+++ b/fix-musicbrainz.patch
@@ -0,0 +1,12 @@
+diff -Naur a/ripit.pl b/ripit.pl
+--- a/ripit.pl 2023-09-27 18:45:51.850903793 -0700
++++ b/ripit.pl 2023-09-27 18:46:20.561383811 -0700
+@@ -12042,7 +12042,7 @@
+ exit 0;
+ }
+
+- eval { require WebService::MusicBrainz::Release } if($mb == 1);
++ eval { require WebService::MusicBrainz } if($mb == 1);
+ if($@) {
+ print "\nPlease install WebService::MusicBrainz and dependencies",
+ "\nfrom your closest CPAN mirror before trying again with",