summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--remove_flann.patch16
3 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13449d458abe..9864b6c57ad5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Sep 21 20:18:34 UTC 2017
+# Thu Mar 22 06:55:32 UTC 2018
pkgbase = ros-kinetic-ompl
pkgdesc = ROS - OMPL is a free sampling-based motion planning library.
pkgver = 1.2.1
- pkgrel = 3
+ pkgrel = 4
url = http://ompl.kavrakilab.org
arch = any
license = BSD
@@ -14,7 +14,9 @@ pkgbase = ros-kinetic-ompl
depends = boost
depends = eigen
source = ros-kinetic-ompl-1.2.1-1.tar.gz::https://github.com/ros-gbp/ompl-release/archive/release/kinetic/ompl/1.2.1-1.tar.gz
+ source = remove_flann.patch
sha256sums = 391308ebe4feb777c6b6dc8eb7ae3b4657ac33e23abce3c2d3b3d7aa77af5b1a
+ sha256sums = 467f87f21feababfb43e1b7f581f756333e9a80fd1dd43d64d451c3cf71fe9fc
pkgname = ros-kinetic-ompl
diff --git a/PKGBUILD b/PKGBUILD
index 3839208e269f..07934a72bfaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-kinetic-ompl'
pkgver='1.2.1'
_pkgver_patch=1
arch=('any')
-pkgrel=3
+pkgrel=4
license=('BSD')
ros_makedepends=()
@@ -29,8 +29,15 @@ depends=(${ros_depends[@]}
# Tarball version (faster download)
_dir="ompl-release-release-kinetic-ompl-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ompl-release/archive/release/kinetic/ompl/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('391308ebe4feb777c6b6dc8eb7ae3b4657ac33e23abce3c2d3b3d7aa77af5b1a')
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ompl-release/archive/release/kinetic/ompl/${pkgver}-${_pkgver_patch}.tar.gz"
+ remove_flann.patch)
+sha256sums=('391308ebe4feb777c6b6dc8eb7ae3b4657ac33e23abce3c2d3b3d7aa77af5b1a'
+ '467f87f21feababfb43e1b7f581f756333e9a80fd1dd43d64d451c3cf71fe9fc')
+
+prepare() {
+ cd ${srcdir}
+ patch -p1 < remove_flann.patch
+}
build() {
# Use ROS environment variables
diff --git a/remove_flann.patch b/remove_flann.patch
new file mode 100644
index 000000000000..6ffee0003842
--- /dev/null
+++ b/remove_flann.patch
@@ -0,0 +1,16 @@
+--- a/ompl-release-release-kinetic-ompl-1.2.1-1/CMakeLists.txt 2016-11-19 10:12:22.000000000 -0800
++++ b/ompl-release-release-kinetic-ompl-1.2.1-1/CMakeLists.txt 2018-03-21 22:46:16.837486644 -0700
+@@ -116,13 +116,6 @@
+ include_directories(SYSTEM ${TRIANGLE_INCLUDE_DIR})
+ endif()
+
+-# If FLANN is installed, a wrapper for its nearest neighbor data structures can be used
+-find_package(flann 1.8.3 QUIET)
+-if (FLANN_FOUND)
+- set(OMPL_HAVE_FLANN 1)
+- include_directories(SYSTEM "${FLANN_INCLUDE_DIRS}")
+-endif()
+-
+ # R is needed for running Planner Arena locally
+ find_program(R_EXEC R)
+