summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--remove-boost-signals.patch31
3 files changed, 47 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae14bd9a0a96..62716de74dc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 21 23:21:39 UTC 2018
+# Fri Feb 1 20:12:16 UTC 2019
pkgbase = ros-kinetic-roscpp
pkgdesc = ROS - roscpp is a C++ implementation of ROS.
- pkgver = 1.12.13
+ pkgver = 1.12.14
pkgrel = 1
url = http://ros.org/wiki/roscpp
arch = any
@@ -30,8 +30,10 @@ pkgbase = ros-kinetic-roscpp
depends = ros-kinetic-cpp-common
depends = ros-kinetic-rosgraph-msgs
depends = ros-kinetic-rosconsole
- source = ros-kinetic-roscpp-1.12.13-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/kinetic/roscpp/1.12.13-0.tar.gz
- sha256sums = 87a23de306e34a771799b7bc1447a7c89248e854f7d0b230378cdb0b2e91c02f
+ source = ros-kinetic-roscpp-1.12.14-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/kinetic/roscpp/1.12.14-0.tar.gz
+ source = remove-boost-signals.patch
+ sha256sums = 4520279b2c32794d79ca4217ab61bc92cb6229d71a04312859b71d95f794e1a0
+ sha256sums = 5336533800118ae1defcd3a7e9e2da4daa6adcbc2c97759a5a3bff1926f527b8
pkgname = ros-kinetic-roscpp
diff --git a/PKGBUILD b/PKGBUILD
index 3e25b23a7a5a..81ffdf541443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - roscpp is a C++ implementation of ROS."
url='http://ros.org/wiki/roscpp'
pkgname='ros-kinetic-roscpp'
-pkgver='1.12.13'
+pkgver='1.12.14'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -44,8 +44,15 @@ depends=(${ros_depends[@]})
# Tarball version (faster download)
_dir="ros_comm-release-release-kinetic-roscpp-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/kinetic/roscpp/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('87a23de306e34a771799b7bc1447a7c89248e854f7d0b230378cdb0b2e91c02f')
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/kinetic/roscpp/${pkgver}-${_pkgver_patch}.tar.gz"
+ "remove-boost-signals.patch")
+sha256sums=('4520279b2c32794d79ca4217ab61bc92cb6229d71a04312859b71d95f794e1a0'
+ '5336533800118ae1defcd3a7e9e2da4daa6adcbc2c97759a5a3bff1926f527b8')
+
+prepare() {
+ cd "${srcdir}/${_dir}"
+ patch -p3 -i "${srcdir}/remove-boost-signals.patch"
+}
build() {
# Use ROS environment variables
diff --git a/remove-boost-signals.patch b/remove-boost-signals.patch
new file mode 100644
index 000000000000..412c9551cb89
--- /dev/null
+++ b/remove-boost-signals.patch
@@ -0,0 +1,31 @@
+From 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70 Mon Sep 17 00:00:00 2001
+From: Maarten de Vries <maarten@de-vri.es>
+Date: Thu, 31 Jan 2019 00:58:29 +0100
+Subject: [PATCH] Remove signals from find_package(Boost COMPONENTS ...)
+ (#1580)
+
+The packages use signals2, not signals. Only boost libraries with
+compiled code should be passed to find_package(Boost COMPONENTS ...),
+and the signals2 library has always been header only.
+
+Boost 1.69 has removed the deprecated signals library, so the otherwise
+useless but harmless `signals` component now breaks the build.
+---
+ clients/roscpp/CMakeLists.txt | 2 +-
+ test/test_roscpp/CMakeLists.txt | 2 +-
+ utilities/message_filters/CMakeLists.txt | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/clients/roscpp/CMakeLists.txt b/clients/roscpp/CMakeLists.txt
+index a5d354ea6..8f462df2c 100644
+--- a/clients/roscpp/CMakeLists.txt
++++ b/clients/roscpp/CMakeLists.txt
+@@ -22,7 +22,7 @@ list(GET roscpp_VERSION_LIST 2 roscpp_VERSION_PATCH)
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/include/ros/common.h.in ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros/common.h)
+
+-find_package(Boost REQUIRED COMPONENTS chrono filesystem signals system)
++find_package(Boost REQUIRED COMPONENTS chrono filesystem system)
+
+ include_directories(include ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+