summarylogtreecommitdiffstats
path: root/remove-boost-signals.patch
diff options
context:
space:
mode:
Diffstat (limited to 'remove-boost-signals.patch')
-rw-r--r--remove-boost-signals.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/remove-boost-signals.patch b/remove-boost-signals.patch
new file mode 100644
index 000000000000..412c9551cb89
--- /dev/null
+++ b/remove-boost-signals.patch
@@ -0,0 +1,31 @@
+From 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70 Mon Sep 17 00:00:00 2001
+From: Maarten de Vries <maarten@de-vri.es>
+Date: Thu, 31 Jan 2019 00:58:29 +0100
+Subject: [PATCH] Remove signals from find_package(Boost COMPONENTS ...)
+ (#1580)
+
+The packages use signals2, not signals. Only boost libraries with
+compiled code should be passed to find_package(Boost COMPONENTS ...),
+and the signals2 library has always been header only.
+
+Boost 1.69 has removed the deprecated signals library, so the otherwise
+useless but harmless `signals` component now breaks the build.
+---
+ clients/roscpp/CMakeLists.txt | 2 +-
+ test/test_roscpp/CMakeLists.txt | 2 +-
+ utilities/message_filters/CMakeLists.txt | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/clients/roscpp/CMakeLists.txt b/clients/roscpp/CMakeLists.txt
+index a5d354ea6..8f462df2c 100644
+--- a/clients/roscpp/CMakeLists.txt
++++ b/clients/roscpp/CMakeLists.txt
+@@ -22,7 +22,7 @@ list(GET roscpp_VERSION_LIST 2 roscpp_VERSION_PATCH)
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/include/ros/common.h.in ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros/common.h)
+
+-find_package(Boost REQUIRED COMPONENTS chrono filesystem signals system)
++find_package(Boost REQUIRED COMPONENTS chrono filesystem system)
+
+ include_directories(include ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+