summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10ecc2b181ca..5fc0b0a5fe05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ros-melodic-rosdiagnostic
+pkgbase = ros-noetic-rosdiagnostic
pkgdesc = ROS - Command to print aggregated diagnostic contents to the command line.
pkgver = 1.9.3
pkgrel = 2
@@ -7,11 +7,11 @@ pkgbase = ros-melodic-rosdiagnostic
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-catkin
- depends = ros-melodic-rospy
- depends = ros-melodic-diagnostic-msgs
- source = ros-melodic-rosdiagnostic-1.9.3.tar.gz::https://github.com/ros/diagnostics/archive/1.9.3.tar.gz
+ makedepends = ros-noetic-catkin
+ depends = ros-noetic-rospy
+ depends = ros-noetic-diagnostic-msgs
+ source = ros-noetic-rosdiagnostic-1.9.3.tar.gz::https://github.com/ros/diagnostics/archive/1.9.3.tar.gz
sha256sums = 3b2d3bb7bb333b8685fa084e086c00a044803dac41ff58351161440931d23550
-pkgname = ros-melodic-rosdiagnostic
+pkgname = ros-noetic-rosdiagnostic
diff --git a/PKGBUILD b/PKGBUILD
index 58c4f82906bd..cd81bba18566 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgdesc="ROS - Command to print aggregated diagnostic contents to the command line."
url='https://github.com/ros/diagnostics'
-pkgname='ros-melodic-rosdiagnostic'
+pkgname='ros-noetic-rosdiagnostic'
pkgver='1.9.3'
arch=('any')
pkgrel=2
license=('BSD')
ros_makedepends=(
- ros-melodic-catkin
+ ros-noetic-catkin
)
makedepends=(
@@ -20,8 +20,8 @@ makedepends=(
)
ros_depends=(
- ros-melodic-rospy
- ros-melodic-diagnostic-msgs
+ ros-noetic-rospy
+ ros-noetic-diagnostic-msgs
)
depends=(
@@ -35,24 +35,17 @@ sha256sums=('3b2d3bb7bb333b8685fa084e086c00a044803dac41ff58351161440931d23550')
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}