summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--rtaudio.patch83
3 files changed, 4 insertions, 96 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc8527ca4114..eb147e529ec6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdrpp-git
pkgdesc = The bloat-free SDR receiver
- pkgver = 1.0.4.r537.ead2ac6
+ pkgver = 1.0.4.r561.eab4264
pkgrel = 1
url = https://www.sdrpp.org/
arch = x86_64
@@ -40,8 +40,6 @@ pkgbase = sdrpp-git
provides = sdrpp
conflicts = sdrpp
source = sdrpp::git+https://github.com/AlexandreRouma/SDRPlusPlus.git
- source = rtaudio.patch
b2sums = SKIP
- b2sums = 1a08a82edd076b292f1c420c33bc1ba4e038a0b05f32d71927c4f4c0be4f713c3265c11f765eb16721405a5e3abbc443ad57fa0566e36a14b4cb4ec95cd901f1
pkgname = sdrpp-git
diff --git a/PKGBUILD b/PKGBUILD
index 9a05f240b4c1..fe26c9e82337 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=sdrpp
pkgname="$_pkgname-git"
-pkgver=1.0.4.r537.ead2ac6
+pkgver=1.0.4.r561.eab4264
pkgrel=1
pkgdesc="The bloat-free SDR receiver"
arch=(x86_64)
@@ -16,15 +16,8 @@ makedepends=(cmake git "${_plugindeps[@]}")
optdepends=("${_plugindeps[@]}")
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/AlexandreRouma/SDRPlusPlus.git"
- "rtaudio.patch")
-b2sums=('SKIP'
- '1a08a82edd076b292f1c420c33bc1ba4e038a0b05f32d71927c4f4c0be4f713c3265c11f765eb16721405a5e3abbc443ad57fa0566e36a14b4cb4ec95cd901f1')
-
-prepare() {
- cd $_pkgname
- patch --forward --strip=1 --input="$srcdir/rtaudio.patch"
-}
+source=("$_pkgname::git+https://github.com/AlexandreRouma/SDRPlusPlus.git")
+b2sums=('SKIP')
pkgver() {
git -C $_pkgname describe --long --tags --exclude nightly | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
diff --git a/rtaudio.patch b/rtaudio.patch
deleted file mode 100644
index 605682292d64..000000000000
--- a/rtaudio.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From cbd97bf48751baa2c215128aa8b28cb828f522a7 Mon Sep 17 00:00:00 2001
-From: edward-p <edward@edward-p.xyz>
-Date: Wed, 20 Dec 2023 15:54:26 +0800
-Subject: [PATCH] fix for rtaudio6
-
----
- sink_modules/audio_sink/src/main.cpp | 13 ++++++-------
- source_modules/audio_source/src/main.cpp | 11 +++++------
- 2 files changed, 11 insertions(+), 13 deletions(-)
-
-diff --git a/sink_modules/audio_sink/src/main.cpp b/sink_modules/audio_sink/src/main.cpp
-index 15b7c26..5a1bf53 100644
---- a/sink_modules/audio_sink/src/main.cpp
-+++ b/sink_modules/audio_sink/src/main.cpp
-@@ -42,16 +42,15 @@ public:
- device = config.conf[_streamName]["device"];
- config.release(created);
-
-- int count = audio.getDeviceCount();
- RtAudio::DeviceInfo info;
-- for (int i = 0; i < count; i++) {
-+ auto ids = audio.getDeviceIds();
-+ for (int i = 0; i < ids.size(); i++) {
- try {
-- info = audio.getDeviceInfo(i);
-- if (!info.probed) { continue; }
-+ info = audio.getDeviceInfo(ids[i]);
- if (info.outputChannels == 0) { continue; }
-- if (info.isDefaultOutput) { defaultDevId = devList.size(); }
-+ if (info.isDefaultOutput) { defaultDevId = i; }
- devList.push_back(info);
-- deviceIds.push_back(i);
-+ deviceIds.push_back(ids[i]);
- txtDevList += info.name;
- txtDevList += '\0';
- }
-@@ -172,7 +171,7 @@ private:
- audio.startStream();
- stereoPacker.start();
- }
-- catch (RtAudioError& e) {
-+ catch (RtAudioErrorType& e) {
- flog::error("Could not open audio device");
- return false;
- }
-diff --git a/source_modules/audio_source/src/main.cpp b/source_modules/audio_source/src/main.cpp
-index 99efa37..8958c5a 100644
---- a/source_modules/audio_source/src/main.cpp
-+++ b/source_modules/audio_source/src/main.cpp
-@@ -24,7 +24,7 @@ ConfigManager config;
-
- struct DeviceInfo {
- RtAudio::DeviceInfo info;
-- int id;
-+ unsigned int id;
- bool operator==(const struct DeviceInfo& other) const {
- return other.id == id;
- }
-@@ -83,17 +83,16 @@ public:
- void refresh() {
- devices.clear();
-
-- int count = audio.getDeviceCount();
-- for (int i = 0; i < count; i++) {
-+ for (auto id:audio.getDeviceIds()) {
- try {
- // Get info
-- auto info = audio.getDeviceInfo(i);
-+ auto info = audio.getDeviceInfo(id);
-
- // Check that it has a stereo input
-- if (info.probed && info.inputChannels < 2) { continue; }
-+ if (info.inputChannels < 2) { continue; }
-
- // Save info
-- DeviceInfo dinfo = { info, i };
-+ DeviceInfo dinfo = { info, id };
- devices.define(info.name, info.name, dinfo);
- }
- catch (std::exception e) {
---
-2.43.0
-