summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b11c88261ae8..db7f9cf684b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sparky-tube-git
pkgdesc = Download a video file from a web site and convert it to audio or video output file
- pkgver = r35.ec3a763
- pkgrel = 2
+ pkgver = r38.64f7cf9
+ pkgrel = 1
url = https://github.com/sparkylinux/sparky-tube
arch = any
license = GPL3
@@ -9,9 +9,8 @@ pkgbase = sparky-tube-git
depends = ffmpeg
depends = xdg-user-dirs
depends = yad
- depends = youtube-dl
+ depends = yt-dlp
optdepends = vlc: play files
- optdepends = kmplayer: play files
optdepends = mpv: play files
optdepends = smplayer: play files
optdepends = totem: play files
diff --git a/PKGBUILD b/PKGBUILD
index 984cef293083..c04bc723fc89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=sparky-tube-git
-pkgver=r35.ec3a763
-pkgrel=2
-pkgdesc="Download a video file from a web site and convert it to audio or video output file"
-arch=('any')
-url="https://github.com/sparkylinux/sparky-tube"
-license=('GPL3')
-depends=('ffmpeg' 'xdg-user-dirs' 'yad' 'youtube-dl')
-makedepends=('git')
-# 'gmplayer: play files'
+pkgver=r38.64f7cf9
+pkgrel=1
+pkgdesc='Download a video file from a web site and convert it to audio or video output file'
+arch=(any)
+url=https://github.com/sparkylinux/sparky-tube
+license=(GPL3)
+depends=(ffmpeg xdg-user-dirs yad yt-dlp)
+makedepends=(git)
optdepends=('vlc: play files'
- 'kmplayer: play files'
'mpv: play files'
'smplayer: play files'
'totem: play files'
@@ -30,12 +28,12 @@ pkgver() {
}
prepare() {
- sed -i 's|\(/usr\)|'"$pkgdir"'\1|g' $pkgname/install.sh
+ sed -i 's|\(/usr\)|'"$pkgdir"'\1|g' $pkgname/7/install.sh
}
package() {
- cd $pkgname
install -d "$pkgdir/usr/"{bin,share/{applications,pixmaps}}
+
+ cd $pkgname/7
./install.sh
}
-