summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x[-rw-r--r--].SRCINFO23
-rwxr-xr-x[-rw-r--r--]PKGBUILD31
2 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc67ea84a270..5c7a8c25588b 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
-# Generated by mksrcinfo v8
-# Thu May 4 17:33:02 UTC 2017
-pkgbase = sph-dg-guile-git
- pkgdesc = guile bindings to sph-dg
- pkgver = 74
+pkgbase = sph-db-guile-git
+ pkgdesc = guile bindings to sph-db
+ pkgver = 36
pkgrel = 1
- url = http://sph.mn/content/2faf
+ url = http://sph.mn
arch = any
license = gpl3+
makedepends = git
makedepends = gcc
- makedepends = sph-sc
- depends = sph-dg
- depends = guile>=2
- provides = sph-dg-guile
- conflicts = sph-dg-guile
- source = sph-dg-guile-git::git://git.sph.mn/sph-dg-guile#branch=stable
+ depends = sph-db
+ depends = guile
+ provides = sph-db-guile
+ conflicts = sph-db-guile
+ source = git://git.sph.mn/sph-db-guile
md5sums = SKIP
-pkgname = sph-dg-guile-git
+pkgname = sph-db-guile-git
diff --git a/PKGBUILD b/PKGBUILD
index 2b3f222238a0..636ad644c894 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
+pkgname=sph-db-guile-git
arch=(any)
-conflicts=(sph-dg-guile)
-depends=(sph-dg "guile>=2")
+conflicts=(sph-db-guile)
+depends=(sph-db guile)
license=(gpl3+)
-makedepends=(git gcc sph-sc)
+makedepends=(git gcc)
md5sums=(SKIP)
-pkgdesc='guile bindings to sph-dg'
-pkgname=sph-dg-guile-git
-_gitname=sph-dg-guile
+pkgdesc="guile bindings to sph-db"
pkgrel=1
-pkgver=74
-provides=(sph-dg-guile)
-source=("$pkgname::git://git.sph.mn/sph-dg-guile#branch=stable")
-url="http://sph.mn/content/2faf"
+pkgver=36
+provides=(sph-db-guile)
+source=("git://git.sph.mn/sph-db-guile")
+url="http://sph.mn"
pkgver() {
- cd "$pkgname"
+ cd sph-db-guile
git rev-list --count HEAD
}
+build() {
+ cd sph-db-guile
+ export C_INCLUDE_PATH=/usr/include/guile/2.2/
+ ./exe/compile-c
+}
+
package() {
- cd $pkgname
- ./exe/compile && ./exe/install --prefix="${pkgdir}"
+ cd sph-db-guile
+ ./exe/install "${pkgdir}"
} \ No newline at end of file