summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b3f222238a0..636ad644c894 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
+pkgname=sph-db-guile-git
arch=(any)
-conflicts=(sph-dg-guile)
-depends=(sph-dg "guile>=2")
+conflicts=(sph-db-guile)
+depends=(sph-db guile)
license=(gpl3+)
-makedepends=(git gcc sph-sc)
+makedepends=(git gcc)
md5sums=(SKIP)
-pkgdesc='guile bindings to sph-dg'
-pkgname=sph-dg-guile-git
-_gitname=sph-dg-guile
+pkgdesc="guile bindings to sph-db"
pkgrel=1
-pkgver=74
-provides=(sph-dg-guile)
-source=("$pkgname::git://git.sph.mn/sph-dg-guile#branch=stable")
-url="http://sph.mn/content/2faf"
+pkgver=36
+provides=(sph-db-guile)
+source=("git://git.sph.mn/sph-db-guile")
+url="http://sph.mn"
pkgver() {
- cd "$pkgname"
+ cd sph-db-guile
git rev-list --count HEAD
}
+build() {
+ cd sph-db-guile
+ export C_INCLUDE_PATH=/usr/include/guile/2.2/
+ ./exe/compile-c
+}
+
package() {
- cd $pkgname
- ./exe/compile && ./exe/install --prefix="${pkgdir}"
+ cd sph-db-guile
+ ./exe/install "${pkgdir}"
} \ No newline at end of file