summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--fix-missing-stdint-include.patch32
4 files changed, 94 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89e606c05f89..3278e2a43d42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,42 @@
pkgbase = string-machine-git
- pkgdesc = A virtual-analog string ensemble synthesizer LV2 and VST2 plugin
- pkgver = 0.1.0.r25.gb1cc7a5
- pkgrel = 1
+ pkgdesc = A virtual-analog string ensemble synthesizer LV2 and VST2 plugin (git version)
+ pkgver = 0.1.0.r125.g7050cb1
+ pkgrel = 2
url = https://github.com/jpcima/string-machine
arch = i686
arch = x86_64
- groups = pro-audio
groups = lv2-plugins
+ groups = pro-audio
groups = vst-plugins
license = Boost
makedepends = boost
+ makedepends = cairo
+ makedepends = dbus
makedepends = git
- makedepends = mesa
- depends = cairo
+ makedepends = libglvnd
+ depends = glibc
+ depends = gcc-libs
+ depends = libx11
+ depends = libxcursor
+ depends = libxext
+ depends = libxrandr
provides = string-machine
- provides = string-machine=0.1.0
conflicts = string-machine
source = string-machine::git+https://github.com/jpcima/string-machine.git
source = dpf::git+https://github.com/DISTRHO/DPF.git
- md5sums = SKIP
- md5sums = SKIP
+ source = pugl::git+https://github.com/DISTRHO/pugl.git
+ source = fix-missing-stdint-include.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 9c2d6ba762b64c395cb4eb35393eaaaca560692bf48513d34bf6c81fbe350cf5
pkgname = string-machine-git
-
+ depends = glibc
+ depends = gcc-libs
+ depends = libx11
+ depends = libxcursor
+ depends = libxext
+ depends = libxrandr
+ depends = libcairo.so
+ depends = libdbus-1.so
diff --git a/.gitignore b/.gitignore
index 86aed49c40cc..52aee6bef921 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,7 @@
dpf/
+pugl/
string-machine/
pkg/
src/
-.AURINFO
-string-machine-git-*.tar.xz
+string-machine-git-*.pkg.tar.*
string-machine-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4f942f2ef6b0..63fdbdddc095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,53 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=string-machine
-pkgname="${_pkgname}-git"
-pkgver=0.1.0.r25.gb1cc7a5
-pkgrel=1
-pkgdesc="A virtual-analog string ensemble synthesizer LV2 and VST2 plugin"
-arch=('i686' 'x86_64')
+pkgname=$_pkgname-git
+pkgver=0.1.0.r125.g7050cb1
+pkgrel=2
+pkgdesc="A virtual-analog string ensemble synthesizer LV2 and VST2 plugin (git version)"
+arch=(i686 x86_64)
url="https://github.com/jpcima/string-machine"
-license=('Boost')
-depends=('cairo')
-makedepends=('boost' 'git' 'mesa')
-groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
-provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/jpcima/${_pkgname}.git"
- 'dpf::git+https://github.com/DISTRHO/DPF.git')
-md5sums=('SKIP' 'SKIP')
+license=(Boost)
+depends=(glibc gcc-libs libx11 libxcursor libxext libxrandr)
+makedepends=(boost cairo dbus git libglvnd)
+groups=(lv2-plugins pro-audio vst-plugins)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/jpcima/$_pkgname.git"
+ 'dpf::git+https://github.com/DISTRHO/DPF.git'
+ 'pugl::git+https://github.com/DISTRHO/pugl.git'
+ 'fix-missing-stdint-include.patch')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ '9c2d6ba762b64c395cb4eb35393eaaaca560692bf48513d34bf6c81fbe350cf5')
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
+ cd $_pkgname
# See https://github.com/jpcima/string-machine/issues/3#issuecomment-512590428
git describe --long --exclude latest | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_pkgname}"
-
+ cd $_pkgname
+ git submodule init
+ git submodule set-url dpf "$srcdir"/dpf
+ git -c protocol.file.allow=always submodule update
+ cd dpf
git submodule init
- git config submodule.dpf.url "${srcdir}/dpf"
- git submodule update
+ git submodule set-url dgl/src/pugl-upstream "$srcdir"/pugl
+ git -c protocol.file.allow=always submodule update
+ cd ..
+ patch -p1 -N -r - -i "$srcdir"/fix-missing-stdint-include.patch
}
build() {
- cd "${srcdir}/${_pkgname}"
-
+ cd $_pkgname
make
}
package() {
- cd "${srcdir}/${_pkgname}"
-
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ depends+=(libcairo.so libdbus-1.so)
+ cd $_pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}
diff --git a/fix-missing-stdint-include.patch b/fix-missing-stdint-include.patch
new file mode 100644
index 000000000000..408d333eca26
--- /dev/null
+++ b/fix-missing-stdint-include.patch
@@ -0,0 +1,32 @@
+diff --git a/sources/ui/Cairo++.h b/sources/ui/Cairo++.h
+index 50e0b3c..ccab778 100644
+--- a/sources/ui/Cairo++.h
++++ b/sources/ui/Cairo++.h
+@@ -1,6 +1,7 @@
+ #pragma once
+ #include "Geometry.h"
+ #include "Color.h"
++#include <stdint.h>
+ #include <cairo/cairo.h>
+ #include <type_traits>
+ #include <memory>
+diff --git a/sources/ui/Color.h b/sources/ui/Color.h
+index 5c27804..2cf2a28 100644
+--- a/sources/ui/Color.h
++++ b/sources/ui/Color.h
+@@ -1,4 +1,5 @@
+ #pragma once
++#include <stdint.h>
+
+ struct ColorRGBA8 {
+ uint8_t r, g, b, a;
+diff --git a/sources/ui/components/KnobSkin.hpp b/sources/ui/components/KnobSkin.hpp
+index c124817..ef99e91 100644
+--- a/sources/ui/components/KnobSkin.hpp
++++ b/sources/ui/components/KnobSkin.hpp
+@@ -1,4 +1,5 @@
+ #pragma once
++#include <stdint.h>
+ #include "ui/Cairo++.h"
+
+ class KnobSkin {