summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 33 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f942f2ef6b0..63fdbdddc095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,53 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=string-machine
-pkgname="${_pkgname}-git"
-pkgver=0.1.0.r25.gb1cc7a5
-pkgrel=1
-pkgdesc="A virtual-analog string ensemble synthesizer LV2 and VST2 plugin"
-arch=('i686' 'x86_64')
+pkgname=$_pkgname-git
+pkgver=0.1.0.r125.g7050cb1
+pkgrel=2
+pkgdesc="A virtual-analog string ensemble synthesizer LV2 and VST2 plugin (git version)"
+arch=(i686 x86_64)
url="https://github.com/jpcima/string-machine"
-license=('Boost')
-depends=('cairo')
-makedepends=('boost' 'git' 'mesa')
-groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
-provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/jpcima/${_pkgname}.git"
- 'dpf::git+https://github.com/DISTRHO/DPF.git')
-md5sums=('SKIP' 'SKIP')
+license=(Boost)
+depends=(glibc gcc-libs libx11 libxcursor libxext libxrandr)
+makedepends=(boost cairo dbus git libglvnd)
+groups=(lv2-plugins pro-audio vst-plugins)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/jpcima/$_pkgname.git"
+ 'dpf::git+https://github.com/DISTRHO/DPF.git'
+ 'pugl::git+https://github.com/DISTRHO/pugl.git'
+ 'fix-missing-stdint-include.patch')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ '9c2d6ba762b64c395cb4eb35393eaaaca560692bf48513d34bf6c81fbe350cf5')
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
+ cd $_pkgname
# See https://github.com/jpcima/string-machine/issues/3#issuecomment-512590428
git describe --long --exclude latest | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_pkgname}"
-
+ cd $_pkgname
+ git submodule init
+ git submodule set-url dpf "$srcdir"/dpf
+ git -c protocol.file.allow=always submodule update
+ cd dpf
git submodule init
- git config submodule.dpf.url "${srcdir}/dpf"
- git submodule update
+ git submodule set-url dgl/src/pugl-upstream "$srcdir"/pugl
+ git -c protocol.file.allow=always submodule update
+ cd ..
+ patch -p1 -N -r - -i "$srcdir"/fix-missing-stdint-include.patch
}
build() {
- cd "${srcdir}/${_pkgname}"
-
+ cd $_pkgname
make
}
package() {
- cd "${srcdir}/${_pkgname}"
-
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ depends+=(libcairo.so libdbus-1.so)
+ cd $_pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}