summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
-rw-r--r--syncevolution-1.5.3-python2.patch87
-rw-r--r--syncevolution-1.5.3-sslcert.patch16
4 files changed, 13 insertions, 162 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45f213b02977..d8c38bf74f97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,19 @@
pkgbase = syncevolution
pkgdesc = Synchronize PIM data via various protocols
- pkgver = 1.5.3
+ pkgver = 2.0.0
pkgrel = 1
url = https://syncevolution.org/
arch = x86_64
+ arch = aarch64
license = LGPL
makedepends = intltool
makedepends = boost
- makedepends = python
depends = evolution-data-server
depends = libgnome-keyring
depends = neon
- depends = openobex
- depends = python2
- depends = libunique
- source = https://download.01.org/syncevolution/syncevolution/sources/syncevolution-1.5.3.tar.gz
- source = syncevolution-1.5.3-sslcert.patch
- source = syncevolution-1.5.3-python2.patch
- sha256sums = e1195fda09bc7782eb8a55674e9e69d69da4780a9aa4a54d37d84da67ee863c0
- sha256sums = 6904cd9eb9ed4e3eb888bad187315960de9d8a23d69c3c5587e011441cca1494
- sha256sums = 704cbbf11289c5fd82b8c7228661f8cddaa40714598c56b2154783a35630128e
+ depends = python
+ depends = python-pygments
+ source = https://downloads.syncevolution.org/syncevolution/sources/syncevolution-2.0.0.tar.gz
+ sha256sums = 2c5912e6b9a5064710deb8bf059e5058eae26114f6065de79be586ac4c89513e
pkgname = syncevolution
-
-pkgname = syncevolution-http
- pkgdesc = Synchronize PIM data via various protocols (HTTP server)
- arch = any
- depends = syncevolution
- depends = python2-dbus
- depends = python2-twisted
- depends = python2-gobject2
- depends = python2-pyopenssl
- depends = python2-service-identity
-
diff --git a/PKGBUILD b/PKGBUILD
index 0883dae88922..d07722c1236c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,22 @@
# Maintainer: Justus Piater <Justus-dev at Piater dot name>
-pkgname=('syncevolution' 'syncevolution-http')
-pkgver=1.5.3
+pkgname=('syncevolution')
+pkgver=2.0.0
pkgrel=1
pkgdesc="Synchronize PIM data via various protocols"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://syncevolution.org/"
license=('LGPL')
-depends=('evolution-data-server' 'libgnome-keyring' 'neon' 'openobex' 'python2' 'libunique')
-makedepends=('intltool' 'boost' 'python')
-#changelog=
-source=("https://download.01.org/syncevolution/syncevolution/sources/syncevolution-$pkgver.tar.gz"
- "$pkgname-$pkgver-sslcert.patch"
- "$pkgname-$pkgver-python2.patch")
-sha256sums=('e1195fda09bc7782eb8a55674e9e69d69da4780a9aa4a54d37d84da67ee863c0'
- '6904cd9eb9ed4e3eb888bad187315960de9d8a23d69c3c5587e011441cca1494'
- '704cbbf11289c5fd82b8c7228661f8cddaa40714598c56b2154783a35630128e')
+depends=('evolution-data-server' 'libgnome-keyring' 'neon' 'python' 'python-pygments')
+makedepends=('intltool' 'boost')
+source=("https://downloads.syncevolution.org/syncevolution/sources/syncevolution-2.0.0.tar.gz")
-prepare() {
- cd "$pkgname-$pkgver"
- for patch in sslcert python2; do
- patch -p1 -i "$srcdir/$pkgname-$pkgver-$patch.patch"
- done
- autoreconf -fiv
- cd src/synthesis
- autoreconf -fiv
-}
+sha256sums=('2c5912e6b9a5064710deb8bf059e5058eae26114f6065de79be586ac4c89513e')
build() {
cd "$pkgname-$pkgver"
./configure --prefix=/usr \
--libexecdir=/usr/lib/syncevolution \
--sysconfdir=/etc \
- --enable-bluetooth \
--enable-core \
--enable-dbus-service \
--enable-notify \
@@ -48,18 +33,3 @@ package_syncevolution() {
rm -df "$pkgdir/usr/bin/syncevo-http-server" \
"$pkgdir/usr/lib/syncevolution/test"
}
-
-package_syncevolution-http() {
- pkgdesc="Synchronize PIM data via various protocols (HTTP server)"
- arch=('any')
- depends=('syncevolution'
- 'python2-dbus'
- 'python2-twisted'
- 'python2-gobject2'
- 'python2-pyopenssl'
- 'python2-service-identity')
- #changelog=
-
- /usr/bin/install -D "$pkgbase-$pkgver/test/syncevo-http-server.py" \
- "$pkgdir/usr/bin/syncevo-http-server"
-}
diff --git a/syncevolution-1.5.3-python2.patch b/syncevolution-1.5.3-python2.patch
deleted file mode 100644
index 21bd7fa57cc6..000000000000
--- a/syncevolution-1.5.3-python2.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-diff -ura syncevolution-1.5.3.orig/build/source2html.py syncevolution-1.5.3.new/build/source2html.py
---- syncevolution-1.5.3.orig/build/source2html.py 2014-04-25 09:55:47.000000000 +0200
-+++ syncevolution-1.5.3.new/build/source2html.py 2018-03-31 15:07:19.024561185 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
-
- """
- Converts source code (first parameter, can be - for stdin) to HTML
-diff -ura syncevolution-1.5.3.orig/Makefile.in syncevolution-1.5.3.new/Makefile.in
---- syncevolution-1.5.3.orig/Makefile.in 2018-01-09 16:54:29.000000000 +0100
-+++ syncevolution-1.5.3.new/Makefile.in 2018-03-31 15:07:15.649581388 +0200
-@@ -12881,7 +12881,7 @@
- fi; \
- done
- src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
-- $(AM_V_GEN)python $+ >$@
-+ $(AM_V_GEN)python2 $+ >$@
-
- # copy base test files
- $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
-diff -ura syncevolution-1.5.3.orig/src/dbus/server/pim/examples/search.py syncevolution-1.5.3.new/src/dbus/server/pim/examples/search.py
---- syncevolution-1.5.3.orig/src/dbus/server/pim/examples/search.py 2014-10-30 17:54:09.000000000 +0100
-+++ syncevolution-1.5.3.new/src/dbus/server/pim/examples/search.py 2018-03-31 15:07:18.447564681 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python -u
-+#! /usr/bin/python2 -u
- # -*- coding: utf-8 -*-
- # vim: set fileencoding=utf-8 :#
- #
-diff -ura syncevolution-1.5.3.orig/src/dbus/server/pim/examples/sync.py syncevolution-1.5.3.new/src/dbus/server/pim/examples/sync.py
---- syncevolution-1.5.3.orig/src/dbus/server/pim/examples/sync.py 2014-10-30 17:54:09.000000000 +0100
-+++ syncevolution-1.5.3.new/src/dbus/server/pim/examples/sync.py 2018-03-31 15:07:18.022567255 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python -u
-+#! /usr/bin/python2 -u
- # -*- coding: utf-8 -*-
- # vim: set fileencoding=utf-8 :#
- #
-diff -ura syncevolution-1.5.3.orig/src/dbus/server/pim/testpim.py syncevolution-1.5.3.new/src/dbus/server/pim/testpim.py
---- syncevolution-1.5.3.orig/src/dbus/server/pim/testpim.py 2014-10-30 17:54:09.000000000 +0100
-+++ syncevolution-1.5.3.new/src/dbus/server/pim/testpim.py 2018-03-31 15:07:17.623569650 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python -u
-+#! /usr/bin/python2 -u
- # -*- coding: utf-8 -*-
- # vim: set fileencoding=utf-8 :#
- #
-diff -ura syncevolution-1.5.3.orig/src/src.am syncevolution-1.5.3.new/src/src.am
---- syncevolution-1.5.3.orig/src/src.am 2018-01-05 16:10:27.000000000 +0100
-+++ syncevolution-1.5.3.new/src/src.am 2018-03-31 15:07:17.214572102 +0200
-@@ -367,7 +367,7 @@
- nodist_noinst_DATA += src/ClientTest.cpp.html
- CLEANFILES += src/ClientTest.cpp.html
- src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
-- $(AM_V_GEN)python $+ >$@
-+ $(AM_V_GEN)python2 $+ >$@
-
- # copy base test files
- $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
-diff -ura syncevolution-1.5.3.orig/test/log2html.py syncevolution-1.5.3.new/test/log2html.py
---- syncevolution-1.5.3.orig/test/log2html.py 2014-04-25 09:55:47.000000000 +0200
-+++ syncevolution-1.5.3.new/test/log2html.py 2018-03-31 15:07:16.178578268 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
-
- """
- Converts the .log output for a client-test test into HTML, with
-diff -ura syncevolution-1.5.3.orig/test/syncevo-http-server.py syncevolution-1.5.3.new/test/syncevo-http-server.py
---- syncevolution-1.5.3.orig/test/syncevo-http-server.py 2016-09-26 13:20:05.000000000 +0200
-+++ syncevolution-1.5.3.new/test/syncevo-http-server.py 2018-03-31 15:07:16.902573965 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#! /usr/bin/python2
-
- '''Usage: syncevo-http-server.py <URL>
- Runs a SyncML HTTP server under the given base URL.'''
-diff -ura syncevolution-1.5.3.orig/test/syncevo-phone-config.py syncevolution-1.5.3.new/test/syncevo-phone-config.py
---- syncevolution-1.5.3.orig/test/syncevo-phone-config.py 2014-04-25 09:55:48.000000000 +0200
-+++ syncevolution-1.5.3.new/test/syncevo-phone-config.py 2018-03-31 15:07:16.575575908 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #
- # Copyright (C) 2010 Intel Corporation
- #
diff --git a/syncevolution-1.5.3-sslcert.patch b/syncevolution-1.5.3-sslcert.patch
deleted file mode 100644
index 44ff97758e7d..000000000000
--- a/syncevolution-1.5.3-sslcert.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ura syncevolution-1.5.3.orig/src/syncevo/SoupTransportAgent.cpp syncevolution-1.5.3.new/src/syncevo/SoupTransportAgent.cpp
---- syncevolution-1.5.3.orig/src/syncevo/SoupTransportAgent.cpp 2018-01-09 16:53:27.000000000 +0100
-+++ syncevolution-1.5.3.new/src/syncevo/SoupTransportAgent.cpp 2018-03-31 14:58:19.151329884 +0200
-@@ -134,6 +134,11 @@
- g_object_set(m_session.get(), SOUP_SESSION_SSL_CA_FILE, m_cacerts.c_str(), NULL);
- }
- }
-+ else {
-+ // https://lists.syncevolution.org/pipermail/syncevolution/2018-January/005602.html
-+ // Checking enabled by default, disable it.
-+ g_object_set(m_session.get(), SOUP_SESSION_SSL_STRICT, false, NULL);
-+ }
-
- soup_message_set_request(message.get(), m_contentType.c_str(),
- SOUP_MEMORY_TEMPORARY, data, len);
-Only in syncevolution-1.5.3.new/src/syncevo: SoupTransportAgent.cpp~