summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD12
-rw-r--r--tscrape-git.patch29
4 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e31216de8bc..6549e37b0f9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tscrape-git
pkgdesc = Twitter feed scraper
- pkgver = 0.2.r4.gdb47c97
- pkgrel = 2
+ pkgver = 0.4.r9.g8e11f80
+ pkgrel = 1
url = https://git.codemadness.org/tscrape.html
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = tscrape-git
source = tscrape::git+git://git.codemadness.org/tscrape
source = tscrape-git.patch
sha256sums = SKIP
- sha256sums = cfd43838d2172abf6ef708598a3dc4bf2807b30bac637ac2f4a878728586aed2
+ sha256sums = 1912e1fcc8ac0d3edc7dad5a96ffa7091c0057611c2dc538780e4a5e5d809d18
pkgname = tscrape-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2ff2c449d81f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
+!tscrape-git.patch
diff --git a/PKGBUILD b/PKGBUILD
index a9dc8fab0810..afc3a70d5730 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: KingofToasters <dev at sgregoratto dot me>
+# Maintainer: Stephen Gregoratto <dev@sgregoratto.me>
pkgname=tscrape-git
-pkgver=0.2.r4.gdb47c97
-pkgrel=2
+pkgver=0.4.r9.g8e11f80
+pkgrel=1
pkgdesc='Twitter feed scraper'
url='https://git.codemadness.org/tscrape.html'
license=('ISC')
@@ -12,7 +12,7 @@ makedepends=('git')
source=("${pkgname%-git}::git+git://git.codemadness.org/tscrape"
"tscrape-git.patch" )
sha256sums=('SKIP'
- 'cfd43838d2172abf6ef708598a3dc4bf2807b30bac637ac2f4a878728586aed2')
+ '1912e1fcc8ac0d3edc7dad5a96ffa7091c0057611c2dc538780e4a5e5d809d18')
pkgver() {
cd "${pkgname%-git}"
@@ -31,6 +31,6 @@ build() {
package() {
cd "${pkgname%-git}"
- make DESTDIR="$pkgdir/" install
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENCE"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/tscrape-git.patch b/tscrape-git.patch
index 1a4f9c51e545..c732b8734dda 100644
--- a/tscrape-git.patch
+++ b/tscrape-git.patch
@@ -1,31 +1,26 @@
Chunk 1: Change PREFIX variables
-Chunk 2: Append local (C|CXX|LD)FLAGS
-diff -ura tscrape.old/config.mk tscrape.new/config.mk
---- tscrape.old/config.mk 2019-02-26 10:25:11.124019917 +1100
-+++ tscrape.new/config.mk 2019-02-26 10:26:34.482322212 +1100
-@@ -1,9 +1,9 @@
- # customize below to fit your system
+Chunk 2: Append local CPPFLAGS
+diff -ura tscrape.old/Makefile tscrape.new/Makefile
+--- tscrape.old/Makefile 2020-03-30 21:06:13.524958558 +1100
++++ tscrape.new/Makefile 2020-03-30 21:07:54.628158194 +1100
+@@ -4,16 +4,16 @@
+ VERSION = 0.4
# paths
-PREFIX = /usr/local
-MANPREFIX = ${PREFIX}/man
-DOCPREFIX = ${PREFIX}/share/doc/tscrape
-+PREFIX = /usr
++PREFIX = /usr
+MANPREFIX = ${PREFIX}/share/man
+DOCPREFIX = ${PREFIX}/share/doc/tscrape-git
- # compiler and linker
- CC = cc
-@@ -11,9 +11,9 @@
RANLIB = ranlib
# use system flags.
--TSCRAPE_CFLAGS = ${CFLAGS}
--TSCRAPE_LDFLAGS = ${LDFLAGS}
+ TSCRAPE_CFLAGS = ${CFLAGS}
+ TSCRAPE_LDFLAGS = ${LDFLAGS}
-TSCRAPE_CPPFLAGS = -D_DEFAULT_SOURCE
-+TSCRAPE_CFLAGS = ${CFLAGS}
-+TSCRAPE_LDFLAGS = ${LDFLAGS}
-+TSCRAPE_CPPFLAGS += -D_DEFAULT_SOURCE
++TSCRAPE_CPPFLAGS = ${CPPFLAGS} -D_DEFAULT_SOURCE
- # debug
- #TSCRAPE_CFLAGS = -fstack-protector-all -O0 -g -std=c99 -Wall -Wextra -pedantic
+ BIN = \
+ tscrape\