summarylogtreecommitdiffstats
path: root/tscrape-git.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tscrape-git.patch')
-rw-r--r--tscrape-git.patch29
1 files changed, 12 insertions, 17 deletions
diff --git a/tscrape-git.patch b/tscrape-git.patch
index 1a4f9c51e545..c732b8734dda 100644
--- a/tscrape-git.patch
+++ b/tscrape-git.patch
@@ -1,31 +1,26 @@
Chunk 1: Change PREFIX variables
-Chunk 2: Append local (C|CXX|LD)FLAGS
-diff -ura tscrape.old/config.mk tscrape.new/config.mk
---- tscrape.old/config.mk 2019-02-26 10:25:11.124019917 +1100
-+++ tscrape.new/config.mk 2019-02-26 10:26:34.482322212 +1100
-@@ -1,9 +1,9 @@
- # customize below to fit your system
+Chunk 2: Append local CPPFLAGS
+diff -ura tscrape.old/Makefile tscrape.new/Makefile
+--- tscrape.old/Makefile 2020-03-30 21:06:13.524958558 +1100
++++ tscrape.new/Makefile 2020-03-30 21:07:54.628158194 +1100
+@@ -4,16 +4,16 @@
+ VERSION = 0.4
# paths
-PREFIX = /usr/local
-MANPREFIX = ${PREFIX}/man
-DOCPREFIX = ${PREFIX}/share/doc/tscrape
-+PREFIX = /usr
++PREFIX = /usr
+MANPREFIX = ${PREFIX}/share/man
+DOCPREFIX = ${PREFIX}/share/doc/tscrape-git
- # compiler and linker
- CC = cc
-@@ -11,9 +11,9 @@
RANLIB = ranlib
# use system flags.
--TSCRAPE_CFLAGS = ${CFLAGS}
--TSCRAPE_LDFLAGS = ${LDFLAGS}
+ TSCRAPE_CFLAGS = ${CFLAGS}
+ TSCRAPE_LDFLAGS = ${LDFLAGS}
-TSCRAPE_CPPFLAGS = -D_DEFAULT_SOURCE
-+TSCRAPE_CFLAGS = ${CFLAGS}
-+TSCRAPE_LDFLAGS = ${LDFLAGS}
-+TSCRAPE_CPPFLAGS += -D_DEFAULT_SOURCE
++TSCRAPE_CPPFLAGS = ${CPPFLAGS} -D_DEFAULT_SOURCE
- # debug
- #TSCRAPE_CFLAGS = -fstack-protector-all -O0 -g -std=c99 -Wall -Wextra -pedantic
+ BIN = \
+ tscrape\