summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--gstreamer-0.24-support.patch63
3 files changed, 75 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 730dad8d5fe7..1b05d99bf7c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vimix
pkgdesc = Live video editor
pkgver = 0.8.2
- pkgrel = 2
+ pkgrel = 3
url = https://brunoherbelin.github.io/vimix/
arch = x86_64
license = GPL-3.0-or-later
@@ -27,6 +27,7 @@ pkgbase = vimix
source = stb-f4a71b13373436a2866c5d68f8f80ac6f0bc1ffe.tar.gz::https://github.com/nothings/stb/archive/f4a71b13373436a2866c5d68f8f80ac6f0bc1ffe.tar.gz
source = tinyfiledialogs::git+https://git.code.sf.net/p/tinyfiledialogs/code#commit=2681e426ddaebc8e2764a7823b4b9d69564d1684
source = asio-01b4e87c04abd4daec58e40463bcdc150085b269.tar.gz::https://github.com/chriskohlhoff/asio/archive/01b4e87c04abd4daec58e40463bcdc150085b269.tar.gz
+ source = gstreamer-0.24-support.patch
b2sums = fab60f7dc1fddaddee5e6620653396bd36fa96c8ed71013d6b83ed2d920dd49a795e5a5b23bd02d133b5fb25a448cdc9c1cdc2f3532eaf1949a8c5a7551ccc6d
b2sums = SKIP
b2sums = SKIP
@@ -36,5 +37,6 @@ pkgbase = vimix
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
+ b2sums = 627cce5659e49bb1355118828643d22c86c47bd8d9be45381927c192bb253d235e5cbe2e630035d07957b4ca4cfc8c7cb83e63ef264db5227c9d2df2bd33d450
pkgname = vimix
diff --git a/PKGBUILD b/PKGBUILD
index d91afb64056d..cec8c589f93f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _asio_commit=01b4e87c04abd4daec58e40463bcdc150085b269
pkgname=vimix
pkgver=0.8.2
-pkgrel=2
+pkgrel=3
arch=('x86_64')
pkgdesc="Live video editor"
url="https://brunoherbelin.github.io/vimix/"
@@ -32,7 +32,8 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/brunoherbelin/vimix/archive
"link-${_link_commit}.tar.gz::https://github.com/Ableton/link/archive/${_link_commit}.tar.gz"
"stb-${_stb_commit}.tar.gz::https://github.com/nothings/stb/archive/${_stb_commit}.tar.gz"
"tinyfiledialogs::git+https://git.code.sf.net/p/tinyfiledialogs/code#commit=${_tinyfiledialogs_commit}"
- "asio-${_asio_commit}.tar.gz::https://github.com/chriskohlhoff/asio/archive/${_asio_commit}.tar.gz")
+ "asio-${_asio_commit}.tar.gz::https://github.com/chriskohlhoff/asio/archive/${_asio_commit}.tar.gz"
+ 'gstreamer-0.24-support.patch')
b2sums=('fab60f7dc1fddaddee5e6620653396bd36fa96c8ed71013d6b83ed2d920dd49a795e5a5b23bd02d133b5fb25a448cdc9c1cdc2f3532eaf1949a8c5a7551ccc6d'
'SKIP'
'SKIP'
@@ -41,7 +42,8 @@ b2sums=('fab60f7dc1fddaddee5e6620653396bd36fa96c8ed71013d6b83ed2d920dd49a795e5a5
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '627cce5659e49bb1355118828643d22c86c47bd8d9be45381927c192bb253d235e5cbe2e630035d07957b4ca4cfc8c7cb83e63ef264db5227c9d2df2bd33d450')
prepare() {
tar -xzf "dirent-${_dirent_commit}.tar.gz" --strip 1 \
@@ -71,6 +73,10 @@ prepare() {
"$pkgname-$pkgver/src/SessionCreator.cpp"
sed -i '/<iostream>/ a #include <algorithm>' \
"$pkgname-$pkgver/src/SourceControlWindow.cpp"
+
+ # Fix build failure due to latest GStreamer update (version 0.24)
+ patch --forward --strip=1 --input="${srcdir}/gstreamer-0.24-support.patch" \
+ -d "$srcdir/$pkgname-$pkgver"
}
build() {
diff --git a/gstreamer-0.24-support.patch b/gstreamer-0.24-support.patch
new file mode 100644
index 000000000000..ffc264479938
--- /dev/null
+++ b/gstreamer-0.24-support.patch
@@ -0,0 +1,63 @@
+Description: Fix build failure due to latest GStreamer update (version 0.24)
+
+<https://github.com/brunoherbelin/vimix/commit/2d99870ec2d3171a00dbcb045bb8dca629caee60>
+
+diff --unified --recursive --text vimix.orig/src/MediaPlayer.cpp vimix.new/src/MediaPlayer.cpp
+--- vimix.orig/src/MediaPlayer.cpp 2024-01-02 10:20:45.000000000 -0300
++++ vimix.new/src/MediaPlayer.cpp 2024-06-11 00:31:35.132270348 -0300
+@@ -435,6 +435,9 @@
+ GstAppSinkCallbacks callbacks;
+ #if GST_VERSION_MINOR > 18 && GST_VERSION_MAJOR > 0
+ callbacks.new_event = NULL;
++#if GST_VERSION_MINOR > 23
++ callbacks.propose_allocation = NULL;
++#endif
+ #endif
+ callbacks.new_preroll = callback_new_preroll;
+ if (singleFrame()) {
+@@ -612,6 +615,9 @@
+ GstAppSinkCallbacks callbacks;
+ #if GST_VERSION_MINOR > 18 && GST_VERSION_MAJOR > 0
+ callbacks.new_event = NULL;
++#if GST_VERSION_MINOR > 23
++ callbacks.propose_allocation = NULL;
++#endif
+ #endif
+ callbacks.new_preroll = callback_new_preroll;
+ if (singleFrame()) {
+diff --unified --recursive --text vimix.orig/src/Stream.cpp vimix.new/src/Stream.cpp
+--- vimix.orig/src/Stream.cpp 2024-01-02 10:20:45.000000000 -0300
++++ vimix.new/src/Stream.cpp 2024-06-11 00:33:01.270397360 -0300
+@@ -167,6 +167,9 @@
+ GstAppSinkCallbacks callbacks;
+ #if GST_VERSION_MINOR > 18 && GST_VERSION_MAJOR > 0
+ callbacks.new_event = NULL;
++#if GST_VERSION_MINOR > 23
++ callbacks.propose_allocation = NULL;
++#endif
+ #endif
+ callbacks.eos = NULL;
+ callbacks.new_sample = NULL;
+@@ -269,6 +272,9 @@
+ GstAppSinkCallbacks callbacks;
+ #if GST_VERSION_MINOR > 18 && GST_VERSION_MAJOR > 0
+ callbacks.new_event = NULL;
++#if GST_VERSION_MINOR > 23
++ callbacks.propose_allocation = NULL;
++#endif
+ #endif
+ callbacks.new_preroll = callback_new_preroll;
+ if (single_frame_) {
+diff --unified --recursive --text vimix.orig/src/TextSource.cpp vimix.new/src/TextSource.cpp
+--- vimix.orig/src/TextSource.cpp 2024-01-02 10:20:45.000000000 -0300
++++ vimix.new/src/TextSource.cpp 2024-06-11 00:33:55.504650769 -0300
+@@ -127,6 +127,9 @@
+ GstAppSinkCallbacks callbacks;
+ #if GST_VERSION_MINOR > 18 && GST_VERSION_MAJOR > 0
+ callbacks.new_event = NULL;
++#if GST_VERSION_MINOR > 23
++ callbacks.propose_allocation = NULL;
++#endif
+ #endif
+ callbacks.new_preroll = callback_new_preroll;
+ callbacks.eos = callback_end_of_stream;