summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d91afb64056d..cec8c589f93f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _asio_commit=01b4e87c04abd4daec58e40463bcdc150085b269
pkgname=vimix
pkgver=0.8.2
-pkgrel=2
+pkgrel=3
arch=('x86_64')
pkgdesc="Live video editor"
url="https://brunoherbelin.github.io/vimix/"
@@ -32,7 +32,8 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/brunoherbelin/vimix/archive
"link-${_link_commit}.tar.gz::https://github.com/Ableton/link/archive/${_link_commit}.tar.gz"
"stb-${_stb_commit}.tar.gz::https://github.com/nothings/stb/archive/${_stb_commit}.tar.gz"
"tinyfiledialogs::git+https://git.code.sf.net/p/tinyfiledialogs/code#commit=${_tinyfiledialogs_commit}"
- "asio-${_asio_commit}.tar.gz::https://github.com/chriskohlhoff/asio/archive/${_asio_commit}.tar.gz")
+ "asio-${_asio_commit}.tar.gz::https://github.com/chriskohlhoff/asio/archive/${_asio_commit}.tar.gz"
+ 'gstreamer-0.24-support.patch')
b2sums=('fab60f7dc1fddaddee5e6620653396bd36fa96c8ed71013d6b83ed2d920dd49a795e5a5b23bd02d133b5fb25a448cdc9c1cdc2f3532eaf1949a8c5a7551ccc6d'
'SKIP'
'SKIP'
@@ -41,7 +42,8 @@ b2sums=('fab60f7dc1fddaddee5e6620653396bd36fa96c8ed71013d6b83ed2d920dd49a795e5a5
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '627cce5659e49bb1355118828643d22c86c47bd8d9be45381927c192bb253d235e5cbe2e630035d07957b4ca4cfc8c7cb83e63ef264db5227c9d2df2bd33d450')
prepare() {
tar -xzf "dirent-${_dirent_commit}.tar.gz" --strip 1 \
@@ -71,6 +73,10 @@ prepare() {
"$pkgname-$pkgver/src/SessionCreator.cpp"
sed -i '/<iostream>/ a #include <algorithm>' \
"$pkgname-$pkgver/src/SourceControlWindow.cpp"
+
+ # Fix build failure due to latest GStreamer update (version 0.24)
+ patch --forward --strip=1 --input="${srcdir}/gstreamer-0.24-support.patch" \
+ -d "$srcdir/$pkgname-$pkgver"
}
build() {