summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--fix-build-against-current-x-server.diff101
3 files changed, 4 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37b3b5e5c74f..41eaa0e9fdca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xf86-video-qxl-git
pkgdesc = X Window System QXL driver including Xspice server
- pkgver = 0.1.5.16.g52c421c
+ pkgver = 0.1.5.19.g4e1963a
pkgrel = 1
url = https://www.spice-space.org
arch = i686
@@ -18,8 +18,6 @@ pkgbase = xf86-video-qxl-git
conflicts = X-ABI-VIDEODRV_VERSION<25
conflicts = X-ABI-VIDEODRV_VERSION>=26
source = git+https://gitlab.freedesktop.org/xorg/driver/xf86-video-qxl.git
- source = fix-build-against-current-x-server.diff
sha256sums = SKIP
- sha256sums = a5e4292d3a6bc9641a8d4ec4d9eb92094ee3d20581c590051e878c8829b9a035
pkgname = xf86-video-qxl-git
diff --git a/PKGBUILD b/PKGBUILD
index 626bb29824fd..a22220c5a550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,25 @@
_pkgname=xf86-video-qxl
pkgname=$_pkgname-git
-pkgver=0.1.5.16.g52c421c
+pkgver=0.1.5.19.g4e1963a
pkgrel=1
pkgdesc='X Window System QXL driver including Xspice server'
arch=('i686' 'x86_64')
url='https://www.spice-space.org'
license=('MIT')
-#depends=('xf86dgaproto' 'xproto' 'fontsproto' 'randrproto' 'renderproto' 'videoproto' 'resourceproto' 'scrnsaverproto' 'spice')
depends=('spice')
optdepends=('python: Xspice server')
makedepends=('git' 'xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=25.2' 'spice-protocol' 'libcacard')
provides=('xf86-video-qxl')
conflicts=('xf86-video-qxl' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
-source=("git+https://gitlab.freedesktop.org/xorg/driver/$_pkgname.git"
- fix-build-against-current-x-server.diff)
-sha256sums=('SKIP'
- a5e4292d3a6bc9641a8d4ec4d9eb92094ee3d20581c590051e878c8829b9a035)
+source=("git+https://gitlab.freedesktop.org/xorg/driver/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --always | sed 's/xf86-video-qxl.//;s/-/./g'
}
-prepare() {
- cd $_pkgname
- patch -p1 < ../fix-build-against-current-x-server.diff
-}
-
build() {
cd $_pkgname
diff --git a/fix-build-against-current-x-server.diff b/fix-build-against-current-x-server.diff
deleted file mode 100644
index d1a8d7e6f2a9..000000000000
--- a/fix-build-against-current-x-server.diff
+++ /dev/null
@@ -1,101 +0,0 @@
-From 4b083ede3c4a827a84295ff223e34ee3c2e581b2 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Zolt=C3=A1n=20B=C3=B6sz=C3=B6rm=C3=A9nyi?=
- <zboszor@gmail.com>
-Date: Sat, 28 Aug 2021 15:38:40 +0200
-Subject: [PATCH] Fix a build error with Xorg master
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Use xf86ReturnOptValBool() in get_bool_option() instead of
-options[option_index].value.bool to fix a compiler error with
-current Xorg xserver master branch.
-
-Also use xf86GetOptValInteger() in get_int_option() and
-xf86GetOptValString() in get_str_option() for consistency.
-
-The change causes a slight performance drop during option parsing
-because the passed-in index_value is no longer used as an index
-into the options array.
-
-Instead, it's used as a token now for the standard option getter
-functions which works since the index_value to the get_*_option()
-functions are identical to the value of options[n].token in the
-passed-in OptionInfoRec array.
-
-Also rename "int option_index" to "int token" for clarity in all
-three functions.
-
-Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
----
- src/qxl_option_helpers.c | 13 +++++++------
- src/qxl_option_helpers.h | 6 +++---
- 2 files changed, 10 insertions(+), 9 deletions(-)
-
-diff --git a/src/qxl_option_helpers.c b/src/qxl_option_helpers.c
-index 2aba677..7707b7c 100644
---- a/src/qxl_option_helpers.c
-+++ b/src/qxl_option_helpers.c
-@@ -10,31 +10,32 @@
-
- #include "qxl_option_helpers.h"
-
--int get_int_option(OptionInfoPtr options, int option_index,
-+int get_int_option(OptionInfoPtr options, int token,
- const char *env_name)
- {
-+ int value;
- if (env_name && getenv(env_name)) {
- return atoi(getenv(env_name));
- }
-- return options[option_index].value.num;
-+ return xf86GetOptValInteger(options, token, &value) ? value : 0;
- }
-
--const char *get_str_option(OptionInfoPtr options, int option_index,
-+const char *get_str_option(OptionInfoPtr options, int token,
- const char *env_name)
- {
- if (getenv(env_name)) {
- return getenv(env_name);
- }
-- return options[option_index].value.str;
-+ return xf86GetOptValString(options, token);
- }
-
--int get_bool_option(OptionInfoPtr options, int option_index,
-+int get_bool_option(OptionInfoPtr options, int token,
- const char *env_name)
- {
- const char* value = getenv(env_name);
-
- if (!value) {
-- return options[option_index].value.bool;
-+ return xf86ReturnOptValBool(options, token, FALSE);
- }
- if (strcmp(value, "0") == 0 ||
- strcasecmp(value, "off") == 0 ||
-diff --git a/src/qxl_option_helpers.h b/src/qxl_option_helpers.h
-index 7c54c72..66d0a17 100644
---- a/src/qxl_option_helpers.h
-+++ b/src/qxl_option_helpers.h
-@@ -4,13 +4,13 @@
- #include <xf86Crtc.h>
- #include <xf86Opt.h>
-
--int get_int_option(OptionInfoPtr options, int option_index,
-+int get_int_option(OptionInfoPtr options, int token,
- const char *env_name);
-
--const char *get_str_option(OptionInfoPtr options, int option_index,
-+const char *get_str_option(OptionInfoPtr options, int token,
- const char *env_name);
-
--int get_bool_option(OptionInfoPtr options, int option_index,
-+int get_bool_option(OptionInfoPtr options, int token,
- const char *env_name);
-
- #endif // OPTION_HELPERS_H
---
-GitLab
-