summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5367a7016b84..7ce46052c988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,30 @@
# Contributor: Eric Biggers <ebiggers3 at gmail dot com>
pkgname=abyss
-pkgver=2.3.6
-pkgrel=1
+pkgver=2.3.7
+pkgrel=2
pkgdesc="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
arch=("i686" "x86_64")
url="https://github.com/bcgsc/abyss"
license=("GPL3")
-depends=("openmpi" "make")
-makedepends=("boost" "sparsehash" "make" "btllib")
+depends=("openmpi" "make" "sqlite" "perl")
+makedepends=("boost" "sparsehash" "btllib")
optdepends=(
'pigz: for parallel gzip'
'samtools: for reading SAM files'
)
source=("$pkgname-$pkgver.tar.gz::https://github.com/bcgsc/abyss/archive/$pkgver.tar.gz")
-sha512sums=('bc535f2676f6ed9929219680fb301787bffa527892c46f96c10d4e998cd7a7cf88df689f04e3bb4333d4a8ec7f098f6bd45b1a0e20877674d003c7f57eca5268')
+sha512sums=('71fe616724e61174d5034b91de9b0495b7c3d8cd2c3c88981048089003041bab6cad4ff608aac10bcb0846aaac047d73b9d6c2e1f52c0681ac351c5ef5a0831d')
build() {
cd "${pkgname}-${pkgver}"
./autogen.sh
- ./configure --prefix=/usr --with-boost=/usr/lib --with-mpi=/usr/lib/openmpi --with-sparsehash=/usr/lib --with-btllib=/usr/lib --without-sqlite --disable-werror
+ ./configure --prefix=/usr --with-mpi=/usr/lib/openmpi --disable-werror
make
}
package() {
cd "${pkgname}-${pkgver}"
-
make DESTDIR="${pkgdir}" install
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-