summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b444654ecf8..d74df0c6d76c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgname=aseprite
pkgver=1.2.40
_skiaver=m102
_skiahash=861e4743af
-pkgrel=5
+pkgrel=6
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64')
url="https://www.aseprite.org/"
@@ -41,6 +41,8 @@ makedepends=(# "Meta" dependencies
source=("https://github.com/aseprite/aseprite/releases/download/v$pkgver/Aseprite-v$pkgver-Source.zip"
# Which branch a given build of Aseprite requires is noted in its `INSTALL.md`
"skia-$_skiaver.tar.gz::https://github.com/aseprite/skia/archive/refs/tags/$_skiaver-$_skiahash.tar.gz"
+ IXWebSocket-GCC13pt1.patch::https://patch-diff.githubusercontent.com/raw/machinezone/IXWebSocket/pull/389.patch
+ IXWebSocket-GCC13pt2.patch::https://patch-diff.githubusercontent.com/raw/machinezone/IXWebSocket/pull/443.patch
desktop.patch
shared-fmt.patch
# Based on https://patch-diff.githubusercontent.com/raw/aseprite/aseprite/pull/2535.patch
@@ -53,6 +55,8 @@ noextract=("Aseprite-v$pkgver-Source.zip"
"skia-$_skiaver.tar.gz") # Don't extract Aseprite or skia sources at the root
sha256sums=('cd67eaf34ee19ae5584f9052f3b385dcfa41232f38016baf08723b987ae583fb'
'8d76c1ad3693e1fc019eb14d806082148eb4ed7d601474aeeaae601b05a9b3ad'
+ '540bdd2985ec1295137deab99b95cb484934ab5d6d3b080fbc21d15e50a5e429'
+ '5c188f30ebf15013f346ef2868d6cfeb84f7ee8ac68f837fee6269aabfa4ae59'
'8b14e36939e930de581e95abf0591645aa0fcfd47161cf88b062917dbaaef7f9'
'821f1354dbbc0bb3fa700e63037ed3c89b0d32bd2ab253450f91eeacd7d47c06'
'd7f2f8c43d24382453273ed17b1c0e05928980a36ad0b7c988da3aa0fe32de53'
@@ -77,6 +81,8 @@ prepare() {
# Their "FindSkia" module forcefully tries to use Skia's FreeType and HarfBuzz,
# but we don't clone those because we use the shared ones. Avoid overwriting the settings instead.
env -C aseprite patch -tp1 <shared-skia-deps.patch
+ env -C aseprite/third_party/IXWebSocket patch -tp1 <IXWebSocket-GCC13pt1.patch
+ env -C aseprite/third_party/IXWebSocket patch -tp1 <IXWebSocket-GCC13pt2.patch
}
build() {