summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22ebe9a91aff..d1ecee0c2793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,8 +27,12 @@ build() {
}
check() {
- # Set HOME to isolate some tests, which accesses files in ~/.ssh/, etc.
- HOME=tmp make -C $_pkgname/common test
+ # Isolate some tests, accessing files in ~/.ssh/, etc.
+ HOME=$srcdir/tmp
+ export XDG_CACHE_HOME=$HOME/.cache
+ mkdir -p $XDG_CACHE_HOME
+
+ make -C $_pkgname/common test
rm -rf $_pkgname/common/tmp
}