summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0257d54c344..65ba0dfab885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=bleachbit-cli
_pkgname=bleachbit
pkgver=4.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.'
conflicts=($_pkgname)
provides=("bleachbit=${pkgver}")
@@ -24,6 +24,10 @@ package() {
cd $_pkgname-$pkgver
make prefix=/usr DESTDIR="$pkgdir" install
+ # to avoid cache getting generated by executable pre-build it which
+ # makes for a clean uninstall/update
+ python -m compileall -d /usr "$pkgdir"/usr
+ python -O -m compileall -d /usr "$pkgdir"/usr
# suggestion by Meow to force script to operate in cli mode
sed -i 's/if 1/if 0/' "$pkgdir"/usr/bin/bleachbit