summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06a1a8462a95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jörg Thalheim <joerg@higgsboson.tk>
+
+pkgname=git-pull-request
+pkgver=20140430
+pkgrel=1
+pkgdesc="git command to automatically pull locally github pull requests"
+arch=('any')
+url="http://www.splitbrain.org/blog/2011-06/19-automate_github_pull_requests"
+license=('MIT')
+depends=('python2' 'git')
+
+source=("git+https://github.com/splitbrain/git-pull-request.git")
+sha1sums=("SKIP")
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -D -m755 git-pull-request $pkgdir/usr/bin/git-pull-request
+}