summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD99
1 files changed, 54 insertions, 45 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79df7f2a4055..bfb6f0586b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,82 @@
-# Maintainer: Davi da Silva Böger <dsboger@gmail.com>
+# Maintainer: Jason Edson <jaysonedson@gmail.com>
+# Contributor: Davi da Silva Böger <dsboger@gmail.com>
# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
# Contributor: Fernando Fernandez <fernando@softwareperonista.com.ar>
# Contributor: Jan de Groot <jgc@archlinux.org>
_pkgname='gnome-terminal'
pkgname="${_pkgname}-fedora"
-pkgver=3.30.1
-pkgrel=1
+pkgver=3.50.1
+pkgrel=2
pkgdesc='The GNOME Terminal Emulator with Fedora patches'
-arch=('i686' 'x86_64')
url='https://wiki.gnome.org/Apps/Terminal'
license=('GPL')
-depends=('vte3-notification>=0.54.1' 'gsettings-desktop-schemas' 'dconf')
-makedepends=('intltool' 'itstool' 'docbook-xsl' 'libnautilus-extension'
- 'appdata-tools' 'gnome-shell' 'gconf' 'vala' 'yelp-tools')
-optdepends=('gconf: for gnome-terminal-migration'
- 'libnautilus-extension: for "Open Terminal Here" in GNOME Files')
+arch=(
+ 'i686'
+ 'x86_64'
+)
+depends=(
+ 'libhandy'
+ 'gsettings-desktop-schemas'
+ 'vte3-notification>=0.74.0'
+)
+makedepends=(
+ 'git'
+ 'docbook-xsl'
+ 'libnautilus-extension'
+ 'gnome-shell'
+ 'meson'
+ 'yelp-tools'
+)
+optdepends=(
+ 'gconf: for gnome-terminal-migration'
+ 'libnautilus-extension: for "Open Terminal Here" in GNOME Files'
+)
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
options=('!emptydirs')
groups=('gnome')
-# Fedora patches: http://src.fedoraproject.org/cgit/rpms/gnome-terminal.git/tree/
-_frepourl='http://src.fedoraproject.org/rpms/gnome-terminal'
-_frepobranch='f28'
-_fcommit='d29daedd37ef628fdd8668a9f460e1b6fb853f74'
-_fpatchfile1='0001-build-Don-t-treat-warnings-as-errors.patch'
-_fpatchfile2='gnome-terminal-notify-open-title-transparency.patch'
+
+# Fedora patches: https://src.fedoraproject.org/cgit/rpms/gnome-terminal.git/tree/
+_frepourl='https://src.fedoraproject.org/rpms/gnome-terminal'
+_frepobranch='rawhide'
+_fcommit='3ce2722532b31f2cf348745df07012c0f8c21d28'
+_fpatchfile100='gnome-terminal-cntr-ntfy-autottl-ts.patch'
_fgsoverridefile='org.gnome.Terminal.gschema.override'
+
source=(
- "https://download.gnome.org/sources/${_pkgname}/${pkgver::4}/${_pkgname}-${pkgver}.tar.xz"
- "${_fpatchfile1}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile1}"
- "${_fpatchfile2}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile2}"
- "${_fgsoverridefile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fgsoverridefile}"
+ "git+https://gitlab.gnome.org/GNOME/gnome-terminal.git#tag=${pkgver}"
+ "${_fpatchfile100}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile100}"
+ "${_fgsoverridefile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fgsoverridefile}"
+)
+sha256sums=(
+ 'SKIP'
+ '5b8392072b90fb64dbaa9de90f9cfc8b873b328d520d90781bb4ef471a477cea'
+ 'a4a22834d6524fb697a8edf91c9489617d5ab2e513413fc84c6b8575320938f9'
)
-sha256sums=('e90720d4581da29d7c47d35d4fe81b46a9b4fbdb85e3b6b67dec298552b13228'
- 'f2bc35ec3e0230606ed424225cf8a8aad5149b59880fc4caf3db68a52f534986'
- '9fbad3925a97c1807d193da2632535bc8b41566fee2d8ed1cd825cb67496d3c4'
- 'a4a22834d6524fb697a8edf91c9489617d5ab2e513413fc84c6b8575320938f9')
prepare () {
- cd "${_pkgname}-${pkgver}"
+ cd ${_pkgname}
- patch -p1 -i "../${_fpatchfile1}-${_fcommit}"
- patch -p1 -i "../${_fpatchfile2}-${_fcommit}"
-
- autoreconf -fvi
+ # Apply patches
+ patch -p1 -i "../${_fpatchfile100}-${_fcommit}"
}
build() {
- cd "${_pkgname}-${pkgver}"
- LDFLAGS+=" -pthread" ./configure --prefix='/usr' \
- --sysconfdir='/etc' \
- --localstatedir='/var' \
- --libexecdir="/usr/lib/${_pkgname}" \
- --disable-static \
- --with-nautilus-extension
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
-}
+ local meson_options=(
+ -D b_lto=false
+ -D docs=true
+ -D nautilus_extension=true
+ -D search_provider=true
+ )
-check() {
- cd "${_pkgname}-${pkgver}"
- make check
+ arch-meson build gnome-terminal "${meson_options[@]}"
+ meson compile -C build
}
package() {
- cd "${_pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ meson install -C build --destdir "${pkgdir}"
- install -Dm644 "../${_fgsoverridefile}-${_fcommit}" \
- "${pkgdir}/usr/share/glib-2.0/schemas/${_fgsoverridefile}"
+ install -Dm644 "${srcdir}/${_fgsoverridefile}-${_fcommit}" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/${_fgsoverridefile}"
}