summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad46f60a0999..60f304209644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Original Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+#
+# Copied from AUR3
+#
pkgname=libkdcraw-frameworks-git
-pkgver=5.0.0.r1094.755c55c
+pkgver=5.0.0.r1055.9850efb
pkgrel=1
-pkgdesc="A C++ interface used to decode RAW picture. KF5 Frameworks branch. (GIT version)"
-arch=('i686' 'x86_64')
+pkgdesc="A C++ interface used to decode RAW picture. KF5 Frameworks branch (GIT version)"
url='https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw'
+arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL')
-depends=('qt5-base'
- 'libraw'
- )
-makedepends=('extra-cmake-modules'
- 'kdoctools'
- 'git'
- 'python'
- )
+depends=('kconfig' 'ki18n' 'libraw' 'hicolor-icon-theme')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
conflicts=('libkdcraw')
-source=('git://anongit.kde.org/libkdcraw#branch=frameworks')
+provides=('libkdcraw')
+source=("git://anongit.kde.org/libkdcraw#branch=frameworks")
sha1sums=('SKIP')
install=libkdcraw-frameworks-git.install
pkgver() {
cd libkdcraw
- _ver="$(cat CMakeLists.txt | grep -m3 -e KDCRAW_LIB_MAJOR_VERSION -e KDCRAW_LIB_MINOR_VERSION -e KDCRAW_LIB_PATCH_VERSION | cut -d '"' -f2 | paste -sd'.')"
- echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ _ver="$(cat CMakeLists.txt | grep -e KDCRAW_LIB_MAJOR_VERSION -e KDCRAW_LIB_MINOR_VERSION -e KDCRAW_LIB_PATCH_VERSION | head -n3 | cut -d '"' -f2)"
+ echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
@@ -44,3 +42,4 @@ build() {
package() {
make -C build DESTDIR="${pkgdir}" install
}
+