summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD128
1 files changed, 66 insertions, 62 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66683eb0be5f..9827fc90867d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Sam Burgos <santiago.burgos1089@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Morfeo <morfeo89@hotmail.it>
pkgbase=lightdm-guest
pkgname=(
lightdm-guest
liblightdm-qt5-guest
)
-pkgver=1.30.0
-pkgrel=3
+pkgver=1.32.0
+pkgrel=1
epoch=1
pkgdesc='A lightweight display manager. With guest-session enabled'
_add_group=add-autologin-group
arch=(x86_64)
-url=https://www.freedesktop.org/wiki/Software/LightDM/
+url=https://github.com/canonical/lightdm
license=(
GPL3
LGPL3
@@ -35,70 +37,69 @@ makedepends=(
yelp-tools
)
install=$_add_group.install
+_tag=9e72b5b3072ff9990211f35aa2a48e971ff710c7
source=(
- git+https://github.com/CanonicalLtd/lightdm.git#tag=${pkgver}
- lightdm.service
- lightdm.sysusers
- lightdm.tmpfiles
- lightdm.pam
- lightdm-autologin.pam
- lightdm.rules
- lightdm-default-config.patch
- Xsession
- 0001-guest-account-Add-default-GSettings-support.patch
- 0002-guest-account-Enable-autologin-guest-account-command.patch
- $_add_group.script
- $_add_group.service
+ git+https://github.com/CanonicalLtd/lightdm.git?signed#tag=${_tag}
+ lightdm.service
+ lightdm.sysusers
+ lightdm.tmpfiles
+ lightdm.pam
+ lightdm-autologin.pam
+ lightdm.rules
+ lightdm-default-config.patch
+ Xsession
+ 0001-guest-account-Add-default-GSettings-support.patch
+ 0002-guest-account-Enable-autologin-guest-account-command.patch
+ $_add_group.script
+ $_add_group.service
)
-sha256sums=('SKIP'
- '0db37a14521be729411a767f157fbd07adb738b14006277def53a1efe4dacfb8'
- 'fd93291bfc9985f0a1bb288472866aa0a9bcd259e024c3a29d20ca158bc08403'
- 'cd69f928a1a5b30a30ba916e1b64c9f3657597cb28f3f0e220494d6e5e4bf587'
- 'e8c4c5fd3b801a390d201166fd1fb9730e78a5c62928768103b870b6bd980ea0'
- '33e3c3d6e16c8d30756754ea3f31f5457c5be0343686aad287692be34958984a'
- 'a89566307e1c81c24f037d854cbd472d2f94f8a4b759877a01563a332319f7d6'
- '70b1d952d1ea8ade6b5561e6de781cfbfe3a86a116c10ea9774cfae73281c7a6'
- 'd30321a1b490500483b8ed7825fcff2c24a7c760ac627789ff517693888ec3c5'
- 'e4c2c618f5484ba165776b747befadd101e40cfdbe4bc01cbb6d3e22beb6ab65'
- '145fc56dd6d04273cda7058e3d14cfb0cd849ceb7d0089af73be5e69c50fefc6'
- '8b665387245531d4d25ffee9636a3735667876937238c376d7eece97f7a82c14'
- '2199300cc27b6b407e46206abd181b2be2679d2520ddd183e4a37a3fc691739a')
+validpgpkeys=(497851B5D455C606543F2B9318EAA1890F7C882E) # Robert Ancell <robert.ancell@gmail.com>
+b2sums=('SKIP'
+ 'edf722759d922428f5aba6793923e3b1846ddcfab67fe3e2bac109edf16219e037242aa5536fbab346e04295069b4fc0fa98062e3006088ec9780c58e503463a'
+ '901702d0bc471de1f8f796576f4d3b451daf632dd703fecc3be7228f9b8deb911d834cd53e8fd5ee24227f46be6a4789b1983a96ec7c32d170d7427ef00c5293'
+ '8d04b2f9b861a65707bc1965a80f64d4e03cfe09c84addda27e8dca74b40f4fe85c43773e41dcb972772df7684d4bfc2aacd32c9bc1ac9fa1c2a8d6c27cd02b2'
+ '11f4c568c6b766d3baf65ea91be2ec0641381a6c195ef460a9a0e282591c1211603d0a3db630e901079fba28819a4efab45bb8b722947dfac37659daafe14aaf'
+ '3349ad387eb3c928e3314f557800f88abb58eb2d5f2e4ccb882c4469f7ed26f940cd70a89ad33484eb3f14246ea7c7402a24396aeeea7046c002bedace631c26'
+ '9e7b4f2adacfa18e9c029f93b922da45e3326266495a1919465f299fa630d769eaaa2101d76966cea496f66c4bd8469c73ef55acde5cd19fa559921c192acd04'
+ 'f252322abfc5351c076ab64c4891a31fcb4cf806ad186d8287f23ae968164f612ff140da83160ebe7e6633d3b039dc4791fa4dd7dbc363dadec544a341675aa2'
+ '7785c19bb2343732d75dd2abd744148ae8baa6d8ad2b295a8e28d5eb78d7bd525e17784ae8a75784ab4cdb3fde73c66789b1bc033c53dafe13f8d19988e5ba18'
+ '5f684c420f91c7458422e9daf8f75690ffcba6938e71e79a1c97039969d33a76d902699602795a7626ee0e8f0afa987123f9e53356af239360cb9c03b933ae77'
+ 'a79443e9f7e84f7e2baadb40c97c72448cd0f69b1ca49aa1a615d0e937a521b1201450bec7e97a95a43e8a7e1f8490fb8da0eba14b508ea4f494bac7c7164701'
+ '0aaa0792bbfd9057ad98417e218ce9fe032f3f043216270eb2232c98446cccd0b397273ca7f959eaa3f01e31567384d6211dd3961a96ca07b3acae8a9a307a0d'
+ '055dda3ce02e0fd5fc5e5de04941cab2850d10772095fa969780354ea529c1c79b889af935fac26840803b6485ce5afff7fe1b8378784e79ab3fd0b4be53e846')
prepare() {
- cd lightdm
+ cd lightdm
+ patch -Np1 -i ../lightdm-default-config.patch
- patch -Np1 -i ../lightdm-default-config.patch
+ # Do not use Ubuntu's language-tools
+ sed -i '/04_language_handling.patch/d' debian/patches/series
- # Do not use Ubuntu's language-tools
- sed -i '/04_language_handling.patch/d' debian/patches/series
+ for i in $(grep -v '#' debian/patches/series); do
+ patch -p1 -i "debian/patches/${i}"
+ done
- for i in $(grep -v '#' debian/patches/series); do
- patch -p1 -i "debian/patches/${i}"
- done
+ # Add support for settings GSettings/dconf defaults in the guest session. Just
+ # put the files in /etc/guest-session/gsettings/. The file format is the same
+ # as the regular GSettings override files.
+ patch -p1 -i ../0001-guest-account-Add-default-GSettings-support.patch
- # Add support for settings GSettings/dconf defaults in the guest session. Just
- # put the files in /etc/guest-session/gsettings/. The file format is the same
- # as the regular GSettings override files.
- patch -p1 -i ../0001-guest-account-Add-default-GSettings-support.patch
+ # Add support for autologin in the guest session. In Archlinux and derivatives
+ # this is a requirement to enable a fully functional session. It requires adding
+ # the autologin tweak.
+ patch -p1 -i ../0002-guest-account-Enable-autologin-guest-account-command.patch
- # Add support for autologin in the guest session. In Archlinux and derivatives
- # this is a requirement to enable a fully functional session. It requires adding
- # the autologin tweak.
- patch -p1 -i ../0002-guest-account-Enable-autologin-guest-account-command.patch
+ NOCONFIGURE=1 ./autogen.sh
+}
- NOCONFIGURE=1 ./autogen.sh
+pkgver() {
+ cd lightdm
+ git describe --tags
}
build() {
cd lightdm
-
export MOC5=moc-qt5
-
- gtkdocize
- aclocal --install --force
- autoreconf -vfi
- intltoolize -f
-
./configure \
--prefix=/usr \
--libexecdir=/usr/lib/lightdm \
@@ -115,7 +116,6 @@ build() {
package_lightdm-guest() {
depends=(
- bindfs
glib2
libgcrypt
libx11
@@ -130,8 +130,8 @@ package_lightdm-guest() {
'lightdm-gtk-greeter: GTK greeter'
'xorg-server-xephyr: LightDM test mode'
)
- provides=(lightdm)
- conflicts=(lightdm)
+ provides=(lightdm)
+ conflicts=(lightdm)
backup=(
etc/apparmor.d/lightdm-guest-session
etc/lightdm/keys.conf
@@ -151,10 +151,6 @@ package_lightdm-guest() {
rm -rf "${pkgdir}"/etc/init
rm -rf "${pkgdir}"/usr/include/lightdm-qt{,5}-*
- # Dbus
- mv "${pkgdir}"/{etc,usr/share}/dbus-1/system.d
- rmdir "${pkgdir}"/etc/dbus-1
-
# PAM
install -m 644 ../lightdm.pam "${pkgdir}"/etc/pam.d/lightdm
install -m 644 ../lightdm-autologin.pam "${pkgdir}"/etc/pam.d/lightdm-autologin
@@ -197,8 +193,15 @@ package_lightdm-guest() {
# Install autologin systemd service
cd /$srcdir
- install -Dm755 $_add_group.script $pkgdir/usr/bin/$_add_group
- install -Dm644 $_add_group.service $pkgdir/etc/systemd/system/$_add_group.service
+
+ if [ ! -f $pkgdir/usr/bin/$_add_group.script ]; then
+ install -Dm755 $_add_group.script $pkgdir/usr/bin/$_add_group
+ fi
+
+ if [ ! -f $pkgdir/usr/bin/$_add_group.service ]; then
+ install -Dm644 $_add_group.service $pkgdir/etc/systemd/system/$_add_group.service
+ fi
+
}
package_liblightdm-qt5-guest() {
@@ -212,7 +215,6 @@ package_liblightdm-qt5-guest() {
conflicts=(liblightdm-qt5)
cd lightdm
-
make DESTDIR="${pkgdir}" -C liblightdm-gobject install
make DESTDIR="${pkgdir}" -C liblightdm-qt install
make DESTDIR="${pkgdir}" -C liblightdm-gobject uninstall
@@ -220,3 +222,5 @@ package_liblightdm-qt5-guest() {
find "${pkgdir}" -type f -name *qt[!5]* -exec rm {} +
find "${pkgdir}" -type l -name *qt[!5]* -exec rm {} +
}
+
+# vim: ts=2 sw=2 et: