summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23321598867a..e8da081a7d06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-core
-pkgver=0.16.0
+pkgver=0.16.1
pkgrel=1
pkgdesc="Command line tool to build sets of software packages."
arch=(any)
@@ -26,7 +26,7 @@ makedepends=(
python-wheel
)
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/colcon/colcon-core/archive/$pkgver.tar.gz")
-sha256sums=('223e3096b75e4c1537861a0d95585ce8306a7d3ac796c0944658d932eca15539')
+sha256sums=('c8fcde5ae7b29d1c639970fc00b16002fc0e4776bd296f116f8e0f93ae070670')
_pkgname=colcon-core
@@ -35,6 +35,12 @@ build() {
python -m build --wheel --no-isolation
}
+check() {
+ cd "$_pkgname-${pkgver}"
+ python bin/colcon build --paths $_pkgname-${pkgver}
+ python bin/colcon test --paths $_pkgname-${pkgver} --return-code-on-test-failure
+}
+
package() {
cd ${srcdir}/${_pkgname}-${pkgver}
python -m installer --destdir="$pkgdir" dist/*.whl