summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 28 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d63af6fad171..a657e1995ccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Rich Li <rich@dranek.com>
-pkgname='python-xarray'
-_name=${pkgname#python-}
-pkgver=0.14.1
+# Maintainer: Blair Bonnett <blair.bonnett@gmail.com>
+# Contributor: Rich Li <rich@dranek.com>
+
+pkgname=python-xarray
+pkgver=0.15.0
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
url="http://xarray.pydata.org"
@@ -9,30 +10,37 @@ arch=('any')
license=('Apache')
makedepends=('python-setuptools')
depends=('python-numpy' 'python-pandas')
-optdepends=('python-netcdf4: NetCDF4 support'
- 'python-bottleneck: Faster NaN operations'
- 'python-scipy: OPeNDAP support'
- 'python-matplotlib: Plotting support'
- 'python-rasterio: Read GeoTiffs and other gridded raster datasets'
- 'python-dask: Enable out-of-core parallel computation')
+optdepends=(
+ 'python-netcdf4: netCDF4 support'
+ 'python-scipy: Interpolation and fallback netCDF3 support'
+ 'python-h5netcdf: Alternative for netCDF4 support'
+ 'python-zarr: Chunked, compressed N-dimensional arrays'
+ 'python-cftime: Datetime support for non-standard calendars and distant dates'
+ 'python-rasterio: Read GeoTiffs and other gridded raster datasets'
+ 'python-bottleneck: Faster NaN-skipping and rolling window aggregations'
+ 'python-dask: Enable out-of-core parallel computation'
+ 'python-matplotlib: Plotting support'
+ 'python-cartopy: Plotting of cartographic data'
+ 'python-seaborn: Improved color palettes for plots'
+ 'python-sparse: Sparse multi-dimensional arrays'
+
+)
checkdepends=('python-pytest')
replaces=('python-xray')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('b2cbc20f4d91312d2444e6a600f982f5')
-sha1sums=('6c760b4af85e6459296e1c30b590c6f3ef6abd59')
-sha256sums=('04b2f4d24707b8871a7ffa37328d0a2de74e81bd30791c9608712612601abd23')
+source=("https://files.pythonhosted.org/packages/source/x/xarray/xarray-${pkgver}.tar.gz")
+md5sums=('75199f462de36f36b89b3f374ad7ec98')
+sha256sums=('c72d160c970725201f769e80fb91cbad68d6ebf21d68fcc371385a6c950459c3')
build() {
cd "$srcdir/xarray-$pkgver"
python setup.py build
}
-# NB: the default test suite seems to require dask being installed
-# check() {
-# cd "$srcdir/xarray-$pkgver"
-# pytest --disable-warnings xarray
-# }
-
+check() {
+ cd "$srcdir/xarray-$pkgver"
+ pytest
+}
+
package() {
cd "$srcdir/xarray-$pkgver"
python setup.py install --skip-build --prefix=/usr --root="$pkgdir/" --optimize=1