summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e5f42f96126..fa1f4e7be0c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,11 @@
# Maintainer: Jonathan Kohler <kohler.jonathan@gmail.com>
pkgname=python2-labrad-git
-pkgver=0.97.2.e9bb3e6
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ # Git, tags available
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+pkgver=0.97.2.r3.e9bb3e6
pkgrel=1
pkgdesc="LabRAD is a system for quickly and easily building distributed instrument control and data analysis applications. pylabrad provides a python interface to LabRAD."
arch=("any")